0

I installed Manjaro KDE edition a couple days ago. I opened Dolphin and in the Devices section I accessed a Windows drive from which I copied some files. The drive is protected by Bitlocker. Now whenever I log in I get the following dialog:

Disk password dialog

WDC WD30PURX-64P6ZY0 needs a password to be accessed. Please enter a password

How do I get rid of that prompt? What I tried so far:

  • I opened the drive and enabled showing hidden files to check if some utility is creating files there when unlocked. I didn't find anything, only some Microsoft directories ($RECYCLE.BIN, msdownld.tmp, System Volume Information)
  • I removed the drive from Dolphin's "Recent Locations" section. This turned out surprisingly hard to achieve, I ended up using the query from this thread, but it still didn't help.
  • I temporarily uninstalled Dolphin, logged out and back in

1 Answer 1

1

Open System Settings and go to Removable StorageRemovable Devices where the device should be listed, select it and use the Forget Device button to stop KDE from trying to mount it on login.

enter image description here

Note: The UI behaves a little bit strange for me, I had to disconnect the device first, uncheck the On Login and On Attach options for All Known Devices first to be able to use the Forget Device button.

1
  • Thank you, that's the screen I needed. I just ended up unchecking On Login and On Attach instead of clicking Forget Device.
    – Rafał G.
    May 2 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.