I Upgraded to PopOS 22.04 and it is supposed to have Wayland Support, but it isn't working. I tried the following things:

  • Enabled Wayland in /etc/gdm3/custom.conf by setting WaylandEnable=true
  • Installed latest NVIDIA driver 510 (I'm using a GTX 1080)
  • added the line GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1" to /etc/default/grub

Of course I rebooted the PC every time I changed something. There is supposed to be a cog on the bottom right corner when logging in, but no luck so far :(

Has anyone a solution?

  • did you set wayland=true in /etc/gdm3/custom.conf?
    – user542357
    Sep 22, 2022 at 7:30

3 Answers 3


The accepted answer did not provide the solution for me. Instead I found the right hint in this video. I followed these steps to enable Wayland on Pop OS 22.04 as explained in the video:

  • set WaylandEnable=true in /etc/gdm3/custom.conf
  • run systemctl restart gdm.service - note that this will log you out and close all open programs (I guess rebooting should be fine too)
  • at the log in screen, there is a small gear wheel on the bottom right side, choose "Pop on Wayland" instead of "Pop"

In my case I did not have to edit any udev rules or follow other steps. Note that I do not have a NVIDIA card (which is slightly different from the situation in the question).

When using Wayland on Pop OS, you might see an additional application in the ALT+Tab menu when cycling through windows. This is caused by the custom extension "Desktop Icons NG (DING)" which allows to display files on Desktop. It can be disabled in the Extension manager, see this Q&A. I don't know if there is a replacement which does not have this issue.

sudo nano /usr/lib/udev/rules.d/61-gdm.rules

#RUN+="/usr/libexec/gdm-runtime-config set daemon PreferredDisplayServer xorg"

#RUN+="/usr/libexec/gdm-runtime-config set daemon WaylandEnable false"

  • 4
    thanks, this actually helped. To give some context: You have to open the file at /usr/lib/udev/rules.d/61-gdm.rules and comment out the two lines as shown in the contribution May 6, 2022 at 18:56
  • 1
    I commented out these two lines and rebooted, when I run nvidia-smi I see the process /usr/lib/xorg/Xorg. I'm suspecting the change didn't have the expected effect. I also haven't noted any performance differences that I was hoping to see. Jun 27, 2022 at 17:45

Also using POP 22.04 and having the same problem activating Wayland. The Answer presented above allowed me to activate Wayland but the result was not an improvement and I went back to using X. The Wayland screen seemed bright and jittery and the scale was maxed out (very small letters).

I am also running Pop 22.04 on a 2011 Macbookair and have Wayland on it and looking good. Possibly my NVIDIA card on the newer machine needs a driver?

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review
    – dr_
    Nov 13, 2022 at 14:08
  • With some update the above answer isn't supposed to work at all now... It has something to do with nvidia drivers. I think the performance issues you encounter might be the reason why they deactivated Wayland. So at the moment we have to wait. Nov 14, 2022 at 14:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .