-1

I've recently been trying out fish shell and tried to run sudo apt-get update and received the following error:

Err:1 http://us.archive.ubuntu.com/ubuntu impish InRelease
  gpgv, gpgv2 or gpgv1 required for verification, but neither seems installed

gpgv is definitely installed and when I run the update in bash (and zsh) it works fine. I can't find anything in the fish docs or elsewhere about this. Any help much appreciated.

5
  • What fish version? In fish, what's your PATH? Apr 24 at 14:16
  • Also, try running ` sh -c 'env HOME=$(mktemp -d) fish'` to start a Fish shell with no customizations, then see if you can run sudo apt update from inside that shell. Apr 24 at 15:41
  • thanks for comments. i'm using 3.4.1 and my PATH is same as in bash as am using foreign-env in config.fish to source my bashrc. @NotTheDr01ds this worked. So there is obviously something odd going on with my config.fish. Apr 24 at 19:53
  • @JamesEdwards Ok, well, that's still odd :-). Have you found what is causing the problem in your config? I can't imagine it being a PATH modification, since gpgv lives in /usr/bin, same as the apt command in the first place. If you haven't figured it out yet, see if you can provide an overview of your Fish config. Don't just check config.fish, but also ~/.config/fish/conf.d/ and ~/.config/fish/functions/. Apr 25 at 14:45
  • thanks for the help. It seems a bash alias was the problem: alias sudo='sudo PATH=$PATH'. Having disabled that the problem has gone away Apr 28 at 15:17

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.