I have KMail configured to remember my password for both IMAP and SMTP. When receiving mail, I don't have any issues. However, every time I send, it prompts me to enter my password, even though "remember password" is checked.

  1. How can I figure out why Kmail won't remember the password?
  2. How can I make it remember it?

I'm on Arch with i3 (KDE is installed but I don't use it as my DE).

Under Settings/Configure KMail/Accounts/Sending I can select the "Outgoing acocunt" corresponding to my email account and click "Modify". This shows a dialog with a field for the password and "Remember SMTP Password".

In my case, "Password" is blank (not sure if this means it's literally blank or just being hidden) but "Remember SMTP Password" is checked. If I enter my actual SMTP password and click "Ok", the password is still blank when I open the dialog again and I still get prompted when sending email.

  • Sounds like credentials are only stored for inbound mail. I don't know KMail - does it have a separate configuration for setting credentials for outgoing mail?
    – Panki
    Apr 21, 2022 at 17:13
  • @Panki I agree with your assessment. When configuring an account, there are separate tabs for incoming mail credentials and outgoing (SMTP) credentials. I have both filled in (including password and "remember password").
    – Jessica
    Apr 22, 2022 at 13:42
  • Where are your passwords saved ? Using Kmail / Kde-Plasma, passwords are all managed by kwallet and I get all my passwords saved for pops / imaps / smtp accounts.
    – MC68020
    Apr 22, 2022 at 14:23
  • @MC68020 the dialog box is called akonadi_maildispatcher_agent. In Kwallet, I can see this password under Passwords/[domain], imap/akonadi_imap_resource_#rc and mailtransports/### (the keys are ~10 digit numbers).
    – Jessica
    Apr 23, 2022 at 4:21
  • Which distribution is this? I'm seeing this on Debian/testing and I was already wondering whether this was Debian-specific or not (in which case a bug would have to be filed upstream instead of at Debian) Sep 29, 2022 at 6:55


You must log in to answer this question.

Browse other questions tagged .