5

I accidentally killed a session with Ctrl + Alt + Backspace (actually I pressed Shift too but works the same way) and decided I don't want that combination to do that (I have to use similar combinations often and it doesn't ask for confirmation if pressed accidentally).

There were similar questions: https://askubuntu.com/questions/1005618/change-ctrlaltbackspace-to-restart-x-server and this https://askubuntu.com/questions/1357400/change-shortcut-that-restarts-x-server-ctrl-alt-backspace . But although the alternative shortcut is a good idea, they don't say how to disable it.

I tried an answer from Ctrl+Alt+Backspace to kill X server can't be disabled that asks to check for the results of

xmodmap -pke | grep -i server

but this doesn't find anything over the results.

I also tried to remove the shortcut both from the keyboard shortcuts configuration (Settings > Keyboard > Shortcuts > System > Close session) and also by not enabling this option following the steps of this question: https://askubuntu.com/questions/10622/how-can-i-enable-ctrlaltbackspace . That is writing on terminal:

sudo dpkg-reconfigure keyboard-configuration

and leaving everything as it is until the screen with the question

By default the combination Control+Alt+Backspace does not do anything. If you want, you can use it to terminate X Server. Do you want to use Control+Alt+Backspace to kill X Server? ·Yes ·No

I selected No (as it was by default) but still get the unwanted behaviour.

Screenshot with the enabling option for shortcut to kill X Server - in catalan, not english, just to show how it looks: Screenshot with the enabling option for shortcut to kill X Server - in catalan, not english, just to show how it looks

On the file /etc/default/keyboard I have:

XKBOPTIONS=""

I don't know if should report as a bug or there's another layer that overrides this configuration that I'm not aware of.

My system: Kernel: 5.4.0-107-generic x86_64 bits: 64 compiler: gcc v: 9.4.0 Desktop: Cinnamon 4.8.6 wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal

1 Answer 1

1

Go to Menu > System Settings > Keyboard Layouts

Click on Options button, and expand Key sequence to kill the X server and deselected the ctrl+Alt+Backspace. Then close all windows and try this Ctrl-Alt-Backspace again. There should be no more hard reset and hard logout. Just nothing. enter image description here

2
  • thanks a lot! finally saving waste of time
    – jjrr
    Nov 7, 2023 at 22:25
  • And this is successfully ignored by Xorg and kills the server anyway.
    – GreenScape
    Mar 4 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .