1

running RHEL 7.9, with the installation of it as Server with GUI. My [work] operating environment is the server is in a server room and all users connect to it over the network using VNC.

Problem I have as an admin is I can connect into their existing VNC session, with the intent to close it out cleanly prior to doing a reboot... when the user is on travel and leaves an empty vnc session active but I don't know until I connect into it.

But when I do connect into it I hit the GNOME console screen lock within the VNC session, and I don't know the user's password to unlock it...

How in RHEL 7.9 do I globally disable all screen lock and screen savers so that all users will never have a screen saver or screen lock automatically kick in? Preferably I also don't want any user to be able to turn such a thing back on for themself. It is a basic server with gui installation of RHEL 7.9 using the standard GNOME desktop environment / graphical user interface . I am not using KDE or XFCE or anything like that.

1
  • Can you add your desktop environment (e.g. Gnome) to your question?
    – Natolio
    Apr 19 at 15:08

1 Answer 1

2

Give this a try:

Using redhat documentation as reference.

Create the user profile in /etc/dconf/profile/user if it does not already exist:

user-db:user
system-db:local

Edit /etc/dconf/db/local.d/00-screensaver

If there is already a section with the heading: [org/gnome/desktop/screensaver] then just edit/add: lock-enabled=false underneath that heading. If there is not, then create it:

[org/gnome/desktop/screensaver]
lock-enabled=false

Edit /etc/dconf/db/local.d/locks/screensaver (create it if it doesn't exist): Add the following line to the file:

/org/gnome/desktop/screensaver/lock-enabled

This will lock the setting so that users cannot change it.

Run dconf update to update the system databases.

Users may need to restart their gnome session for the change to be picked up.

1
  • 1
    the /etc/dconf/db/local.d/00-screensaver settinglock-enabled=false and idle-activation-enabled=false under [org/gnome/desktop/screensaver] within the file, follwed by a dconf update seemed to do the trick.
    – ron
    Apr 20 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.