0

I am using linux kernel 4.19 on intel (icelake) based server. Sometime immediately after linux boot (at the login prompt) it get stuck(once is 50 reboot or so). It is not responding to anything on serial terminal or monitor. When it get stuck, keyboard caps lock light is not turning on and off. It is not taking even sysrq requests. Only way to recover is to reset the server.

I debugged, tried deadlock debugging, it is not helping. The issue occurs randomly after 10 or sometime 50 reboot. There is no backtrace or oops messages. In what type of situation this can happen? Is it possible that it deadlock in the interrupt context? if yes what is the best way to debug this? Or is may be some type of hardware issue? What else i can do to debug this further?

3
  • 1. Try updating BIOS 2. Remove overclocking/reset BIOS to defaults 3. Use a fresh kernel, e.g. 5.17.2 - 4.19 is too old for this CPU 4. If all the above fails, connect a serial console and check kernel messages - create a bug report with them at bugzilla.kernel.org Apr 12, 2022 at 5:18
  • Using /dev/random or /dev/urandom ? Lack of entropy at boot time ? Can you record /proc/sys/kernel/random/entropy_avail at shtudown time ? (should be >~ 2000)
    – MC68020
    Apr 12, 2022 at 6:52
  • I tried overclocking disabled. Issue went away. But please note that i want to keep the turbo boost enable. Is there something i have to fix in linux kernel?
    – saurin
    Apr 12, 2022 at 17:47

0

You must log in to answer this question.

Browse other questions tagged .