0

So I have a .deb package downloaded. I installed it using sudo apt install ... but it didn't work correctly. I tried removing it using sudo apt purge ... and it said that it can't remove a few directories (\opt... and \var\opt...) so I removed them manually.

I tried installing the package again and it got stock on "Setting up..." for hours. It wouldn't let me shut down my computer (the option was greyed out) so I force shut it down.

Now I can't use apt. Whenever I do, I get E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. but that doesn't work. It gets stuck on Setting up... again.

I tried this:


sudo rm /var/lib/apt/lists/lock

sudo rm /var/cache/apt/archives/lock

cd /var/lib/dpkg/updates

sudo rm *

sudo apt-get update

and then sudo apt remove but then it gets stuck on Removing...

Whenever I try to install something else, it also tries to set up this package and gets stuck.

I don't know what to do, I just want apt/dpkg to jsut ignore this package, not try to set it up or remove it otherwise it always gets stuck and locks apt.

2
  • Take a look at this post
    – crpb
    Apr 11 at 16:56
  • @crpb that did it, thank you!
    – geeshta
    Apr 11 at 21:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.