1

I have a VisionFive V1 risc v single board computer running Fedora. It is connected along with a raspberry pi to a router. The router has port 22 open and a public ip address. I can access the raspberry pi using ssh@public_ip_address but not the VisionFive. I can ssh into the VisionFive from the RaspPi in the subnet: but I want access via the public IP address to the VisionFive. There is no firewall with any filters on either machine. What are the diagnostic steps to identify the cause of the difference / problem. Why is one computer accessible via ssh and the public IP address and the other not? comparison of visionfive and rasppi

9
  • 3
    Do not post pictures. Add the text to the question using codeblocks. Add the contents of the logs to the question as well. Commented Apr 10, 2022 at 20:48
  • How can you distinguish the two systems that use private IP addresses, both behind the single public IP address? Why would one system be selected and not the other? This is done on the router. And I guess only you can tell what was done on the router.
    – A.B
    Commented Apr 10, 2022 at 21:52
  • I'm guessing that your router is set to forward TCP port 22 to your Raspberry Pi (possibly by DMZ). You need to set a different TCP port in the router (e.g. 2222) to be redirected to your VisionFive TCP port 22. Then you can connect from outside using that port e.g. ssh -p54022 root@public_ip_address
    – gogoud
    Commented Apr 11, 2022 at 6:11
  • These are the router settings link. If the pi computer is off, there is still no connection to the Fedora StarFive SBC via ssh over the public ip address. Both the pi and the Fedora StarFive have the same public ip address. Why should one work and not the other.... @gogoud Will test using -p54022 but cannot find any reference for that command..... any help welcome. Commented Apr 11, 2022 at 21:30
  • This question can only be solved on the router. As it is this is not a Unix/Linux question. And of course you can't put the same wan port settings for both systems on the router (its GUI interface should have forbidden such attempt). And no both Fedora StarFive and Pi have a different private IP address and don't have a public IP address: the ones obfuscated on the link.
    – A.B
    Commented Apr 11, 2022 at 21:33

0

You must log in to answer this question.

Browse other questions tagged .