4

Whenever I click an HTTP(S) link in my desktop Teams client it hangs for about 5 seconds, then I get an error saying: "Firefox is already running, but is not responding. To use Firefox, you must first close the existing process, restart your device, or use a different profile."

Needless to say my Firefox is running, responding and has plenty of tabs open. I have no intention to close it or use a different profile.

There is no such issue when I click on any links in other programs, like Thunderbird, Telegram, etc ...

If I do a "ps -ef" with this message open I see the following process tree:

rakula   30542 30440  0 11:42 pts/10   00:00:00 /opt/firefox/firefox-bin https://URL  <-- the "message" process
rakula   30440 23518  0 11:42 pts/10   00:00:00 /bin/sh /usr/bin/xdg-open https://URL
rakula   23518     1  0 11:14 pts/10   00:00:15 /opt/teams/teams --disable-namespace-sandbox --disable-setuid-sandbox

Where the "https://URL" is the link I clicked. "rakula" is my username, my X11 session is running under this user.

If I manually run "/bin/sh /usr/bin/xdg-open https://URL" from a terminal (urxvt) it works as expected - a new tab is opened in a running Firefox window. I am puzzled - what might be the difference between me running this command manually and Teams running the same command - why the later behaves differently?

Gentoo Linux, dwm, Firefox 99, Teams 1.4.00.26453-r1 Firefox is installed from portage firefox-bin package, Teams is also from portage. This issue persists between different versions of Firefox and Teams. I do not experience this issue with Debian Linux and KDE.

2
  • Did you reproduce this with a different browser like Chrome as default browser? I suggest to file it as a defect to Microsoft. MS Teams for Linux is still beta, as far as I know. I experience quite a lot of defects.
    – Philippos
    Apr 8, 2022 at 11:43
  • 1
    I used "xdg-settings set default-web-browser google-chrome.desktop" to test it with chrome as Teams does not allow you to set a default browser. It works - URLs from Teams do open in existing chrome browser. To be honest Teams is a very buggy software. I might follow your advice and submit a bug, but I don't have any faith in it been fixed from MS side. Apr 8, 2022 at 12:12

1 Answer 1

3

It turns out that Teams exports DBUS_SESSION_BUS_ADDRESS=disabled: for some unknown reason.

I created a simple wrapper script and put it into /usr/local/bin/firefox-wrapper.sh:

#!/bin/bash
unset DBUS_SESSION_BUS_ADDRESS
/usr/bin/firefox-bin $*

And edited /usr/share/applications/firefox-bin.desktop, set Exec= to point to my wrapper script.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .