0

yesterday I accidentaly delete some linux partition, before I realize that i deleted some grub config files too...

I run linux, now it shows Welcome to grub rescue.

When i ls it shows (hd0) (hd0,gpt1) (hd0,gpt2) etc.

When i ls [partition] shows somthing like Unknown filesystem.

set root=[partition] and then insmod normal shows no such partition.

I searched for some solutions, but none of them worked...

The worst part is that i cannot go to boot menu and change the boot order, so I CANT BOOT FROM FLASHDRIVE...

Any help welcome.

And sorry for my English.

1

1 Answer 1

0

As I cannot comment yet I have to do it this way. The ls -l comment gives you all disks and partitions with their UUID's.
Why can't you enter the UEFI? Usually there is a Fsomething key to enter it. I can search which key it is if I know what motherboard/laptop you are using.
If you have the possibility to use another computer you can make a flashdrive with Ventoy and put some rescue-iso's ( e.g. Ikki-boot/AiO-SRT/gparted-live/Rescatux/ubuntu-rescue-remix ) and try to recover the lost partition. Remember to write to another disk to avoid overwriting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .