I left town for a few weeks, but kept the desktop running, including many open terminals -- MATE-terminal v 1.24.1. Upon return, I found that left-mouse-button select (highlight-select, for cut-n-paste) stopped working ... for mate-terminal only!

Highlight-select works great in the the web browser, it works in xterm, it works in gnome-terminal. Just not in mate-terminal. (In other words, this shows that mouse kernel dev drivers and X11 seems to be working fine.) The time-stamps on /usr/bin/mate-terminal show that it was not updated while I was away... so I am stumped.


1 Answer 1


And as I was writing the above question, it started working again! I did ls -la /usr/bin/*term* to find anything that might be a terminal, and tried each one of them, to see if cut-n-paste worked. They did. The last one that I tried was /usr/bin/uxterm and after running that, left-mouse select started working (in already-open mate-terminal's.)

I conclude: something in uxterm sets or clears or re-initializes some kind of state in the cut-n-paste buffers, unfreezing them from whatever frozen/invalid/hung state they were in.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .