2

I have set up a new system with a backported debian 11 and KDE Plasma 5 and wanted to continue working on my files. Some of them are from shared project containing Umlaute (ö, ü, ä) which I cannot rename for various reasons. I am asking here because it seems like to be an issue co-depending on the OS and libreoffice at the same time and on my last system with a "regular" debian 11 there werent any issues.

However I am struggling to open those files with the error either saying:

  1. The operation on <path-to-file-with-umlaut> was started with an invalid parameter.
  2. <path-to-file-with-umlaut> does not exist.

Please note, that an exemplary file name would be Stückliste.xlsx displayed with "??".

So far I tried installing the latest libreoffice via aptitude (7.0.4.2) or via flatpak. Neither where able to solve this. I also tried 7.3.1 via direct download from the libreoffice website.

Furthermore in the "Language settings" of libreoffice I tried multiple "locale settings", as my system is setup with the following locale:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_DE.UTF-8
LANGUAGE=en_GB:de
LC_CTYPE="en_DE.UTF-8"
LC_NUMERIC="en_DE.UTF-8"
LC_TIME="en_DE.UTF-8"
LC_COLLATE="en_DE.UTF-8"
LC_MONETARY="en_DE.UTF-8"
LC_MESSAGES="en_DE.UTF-8"
LC_PAPER="en_DE.UTF-8"
LC_NAME="en_DE.UTF-8"
LC_ADDRESS="en_DE.UTF-8"
LC_TELEPHONE="en_DE.UTF-8"
LC_MEASUREMENT="en_DE.UTF-8"
LC_IDENTIFICATION="en_DE.UTF-8"
LC_ALL=

As this shows some issues with locale itself, I had the same settings and issues resulting from it on my old system. So far Ive never been able to address this (I can only assume it results from the mixup between German and English), but libreoffice worked fine on the old system nonetheless.

EDIT1: Both systems were running debian 11 (bullseye) EDIT2: Named an exemplary file name

1
  • Done. One example would be Stückliste, but its the same with other umlaut like ä or ö.
    – Pratched
    Mar 28, 2022 at 22:26

2 Answers 2

3

The is no en_DE Language AFAIK.

Do an sudo dpkg-reconfigure locales and best to Choose all three de_DE-Languages if you work with different Files from different Systems/Persons. I would also suggest you add at least en_US.UTF-8.

It should look like this if everything worked.

> locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE:de
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"

After the dpkg-reconfigure it maybe best to log out and in your User-Session.

3
  • Cheers for your answer. I ran the command and enabled several de as well es en_US.UTF8 and en_GB.UTF8 but after rebooting my system the output of local does not change :/
    – Pratched
    Mar 30, 2022 at 12:20
  • 1
    Then you probably have those Settings in e.g. ~/.bashrc, ~/.profile. Just to make sure it would be a wrong setting in your Environment you could check locale as root or create a new user just to make sure where to look. You could also do an grep -iIR de_EN $HOME.
    – user492934
    Mar 30, 2022 at 22:25
  • Hm yeah I "fixed" the output of locale with manually setting all of them in .bashrc, this works regarding the output. However it does not solve the issue with libreoffice.
    – Pratched
    Mar 31, 2022 at 17:24
1

Recently encountered the same problem.

In addition to the system locale settings, I needed to set the settings in LibreOffice itself.

Tools > Options > Language Settings > Languages - here put correct Locale for the files

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .