1

I had a dual-boot computer with windows and CentOS 8 [A] on it, each one in different partitions. I created a new partition and successfully installed CentOS Stream [B] on it, but now I'm unable to boot into [A].

How can I fix it?

Further details
Disk partitions:

/dev/nvm...p1: /boot
/dev/nvm...p2 to /dev/nvm...p4: not relevant
/dev/nvm...p5: /home partition of [A]
/dev/nvm...p6: swap
/dev/nvm...p7: xfs
/dev/nvm...p8: Logival volume with three subpartitions(?).
    - /dev/cl/root: /root of [A]
    - /dev/cl/home: Not in use.
    - /dev/cl/swap: swap created when installing [A]
/dev/nvm...p9: xfs
/dev/nvm...p10: Logival volume with two subpartitions(?).
    - /dev/cs/root: [B]
    - /dev/cs/swap: swap created when installing [B]

What have I tried?:

After booting into [B], I first substituted all references to cs/root with cl/root in the file /etc/default/grub. After that I executed grub2-mkconfig -o "$(readlink -e /etc/grub.cfg)", as I had read in this question.

After rebooting, four entries with CentOS 8 appear in the grub menu. However, when I try to boot into anyone of them, the system enters an emergency mode and shows the following error: [Failed] Failed to start Switch Root. Running systemctl status initrd-switch-root.service, as proposed here, results in the error description Failed to switch root: Specified switch root path '/sysroot' does not seem to be an OS tree. os-release file is missing.. I've tried the solution proposed there (remounting /sysroot and creating an etc/os-release file inside of it), but it doesn't work. Under the main tree there is already an existing /etc/os-release file in it. At this point, /dev/cl/home is mounted in /sysroot.

What else can I do? Many thanks!

0

You must log in to answer this question.

Browse other questions tagged .