1

I have an issue with my laptops' WIFI

Whenever I connect the home network, the whole machine freezes. I came across drivers to try and fix the problem but I though it is better to use a compatible USB WIFI Dongle that provides better speed than the inbuilt adapter.

The question is, how can I disable the built in and use the USB WIFI Dongle by default?

Please advise me, thank you.

1 Answer 1

2

Bios or Hardware kill switch

You can do this in bios if at all your computer supports this. If your computer has a kill switch for wireless, you can also opt for that.

Blacklist driver

You could blacklist the driver.

  1. Look up your Card Name.

    First, identify your Built-in Adapter Name. Remove the Plugged-in USB Wifi Dongle. Then run:

    ifconfig | grep wl

    The grep Command refines the output List showing only the Entries matching the Keyword.

  2. Discovering Wireless Driver

    Now to find out the Wireless Kernel Module in use, Run:

    readlink /sys/class/net/wlan0/device/driver

    Possibly replace “wlan0” with the identifier found in the former step.

  3. Disabling Wifi Adapter

    To Turn Off Wireless interface, unload the kernel module with:

    sudo modprobe -r [MYMOD]

    Replace with the current one in the above Command. So for instance:

    sudo modprobe -r wl

    Finally, to make the change permanent then Blacklist it editing:

    sudo nano /etc/modprobe.d/blacklist.conf

    And appending the blacklisted Network Interface Module as below:

    blacklist wl

    Ctrl+x to Save & Exit from nano Editor.

lscpi

You can also use lscpi command.

lscpi -k

lspci -k will list all PCI* devices and their drivers. To blacklist add the line below to in /etc/modprobe.d/blacklist.conf

blacklist drivername

This Requires root privilege. Then reboot. The driver won't load if blacklisted. No driver means the interface won't show up in the network commands.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .