0

Overview

I have an Arch Linux/Windows 10 dual boot desktop that I have been using for a few years with little to no issue. Just yesterday I had my WiFi connect working for anywhere from 5 to 30 seconds and then dropping out just to reconnect again. I then went through the process down in the "Thing I've Tried" section and still getting nowhere I am now here. The only other thing to note is the WiFi seems to drop immediately when used for things like pacman updates.

I would appreciate any help with this and I am willing to upload any extra files as needed however I have tried to attach any files and logs I could think might be needed except for my journalctl logs as they are quite long and I am unsure of how to redact them for posting on the internet so any directions there would be appreciated.

Things I've Tried

I started by doing things like checking for multiple network managers running and found that I had dhcpcd running even though NetworkManager doesn't use it so I disabled it. I then logged in to the router and saw that ipv6 is "disconnected" so I tried disabling ipv6 via kernel parameters. While in the router page I also tried assigning a static ip in case the issue was with dhcp assignment somehow but as that did nothing I undid it. I then tried booting into Windows and disabling fast boot because someone had said it helped with a similar problem on another forum post. I then tried booting into a Arch installer and it didn't have the same connectivity issues. Most recently I tried just using systemd-networkd to just check if it was a NetworkManager issue and the issue persisted.

Supplementary Material

iwconfig output:

wlp3s0    IEEE 802.11  ESSID:"118527-2.4G"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 84:D3:43:04:97:D1
          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=59/70  Signal level=-51 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:11   Missed beacon:0

sudo systemctl list-units --type service --no-pager -l output:

  UNIT                                                                                      LOAD   ACTIVE SUB     DESCRIPTION
  dbus.service                                                                              loaded active running D-Bus System Message Bus
  [email protected]                                                                        loaded active running Getty on tty1
  kmod-static-nodes.service                                                                 loaded active exited  Create List of Static Device Nodes
  lvm2-monitor.service                                                                      loaded active exited  Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
  NetworkManager.service                                                                    loaded active running Network Manager
  polkit.service                                                                            loaded active running Authorization Manager
  rtkit-daemon.service                                                                      loaded active running RealtimeKit Scheduling Policy Service
  systemd-binfmt.service                                                                    loaded active exited  Set Up Additional Binary Formats
  systemd-fsck@dev-disk-by\x2duuid-BB3A\x2d636F.service                                     loaded active exited  File System Check on /dev/disk/by-uuid/BB3A-636F
  systemd-fsck@dev-disk-by\x2duuid-f51233b1\x2d0c82\x2d4271\x2dbd8f\x2d46f85c54f510.service loaded active exited  File System Check on /dev/disk/by-uuid/f51233b1-0c82-4271-bd8f-46f85c54f510
  systemd-journal-flush.service                                                             loaded active exited  Flush Journal to Persistent Storage
  systemd-journald.service                                                                  loaded active running Journal Service
  systemd-logind.service                                                                    loaded active running User Login Management
  systemd-modules-load.service                                                              loaded active exited  Load Kernel Modules
  systemd-random-seed.service                                                               loaded active exited  Load/Save Random Seed
  systemd-remount-fs.service                                                                loaded active exited  Remount Root and Kernel File Systems
  systemd-sysctl.service                                                                    loaded active exited  Apply Kernel Variables
  systemd-tmpfiles-setup-dev.service                                                        loaded active exited  Create Static Device Nodes in /dev
  systemd-tmpfiles-setup.service                                                            loaded active exited  Create Volatile Files and Directories
  systemd-udev-trigger.service                                                              loaded active exited  Coldplug All udev Devices
  systemd-udevd.service                                                                     loaded active running Rule-based Manager for Device Events and Files
  systemd-update-utmp.service                                                               loaded active exited  Record System Boot/Shutdown in UTMP
  systemd-user-sessions.service                                                             loaded active exited  Permit User Sessions
  transmission.service                                                                      loaded active running Transmission BitTorrent Daemon
  udisks2.service                                                                           loaded active running Disk Manager
  [email protected]                                                             loaded active exited  User Runtime Directory /run/user/1000
  [email protected]                                                                         loaded active running User Manager for UID 1000
  wpa_supplicant.service                                                                    loaded active running WPA supplicant

inxi output:

System:
  Host: kali Kernel: 5.16.16-arch1-1 arch: x86_64 bits: 64 Desktop: i3
    v: 4.20.1 Distro: Arch Linux
Network:
  Device-1: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
2
  • What's your network card? Is there anything out of place in the dmesg output? Try running dmesg -l err,crit to only list the errors.
    – cryptic
    Commented Mar 23, 2022 at 8:26
  • @Aniket I have no output at all from the dmesg -l err,crit. Also my card is a Rosewill Inc. Wireless Dual Band PCIE card 802.11 Commented Mar 23, 2022 at 15:08

1 Answer 1

3

Can you also post the output of uname -sr or better yet inxi -NS

Your issue might be with the recent release of a fix info leak with DMA_FROM_DEVICE that got integrated in kernels 5.16.15 and 5.16.16 as well as in 5.15.29. You can track the bug here

My current work-around is to use a version of kernel prior to the one that introduced the issue. I'm using 5.16.14-arch1-1

2
  • inxi output will be put in the supplementary material. I tried downgrading both my kernel and my linux-headers but it broke x-org when I rebooted. I am assuming that I am missing a module that needs downgraded or something like that any direction is appreciated. Commented Mar 28, 2022 at 15:38
  • I managed to update linux to 5.17.1 and that resolved the fix info leak with DMA_FROM_DEVICE bug that was causing the wifi issue so I am marking this answer as the answer that resolves this. Commented Mar 30, 2022 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .