0

While doing the doas emerge --ask --verbose --update --deep --newuse @world command, this pops up. It doesn't seem like it updated. (I’m a new Gentoo user, so I don't know much).

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.15.2-r16:5/5.15.2::gentoo, ebuild scheduled for merge) USE="X dbus egl gif jpeg png wayland -accessibility -debug -eglfs -evdev -gles2-only -ibus -libinput -linuxfb -test -tslib -tuio -udev -vnc -vulkan" ABI_X86="(64)" conflicts with
    =dev-qt/qtgui-5.15.2*:5=[egl,libinput,-vulkan,X] required by (dev-qt/qtwayland-5.15.2-r17:5/5.15.2::gentoo, installed) USE="X -debug -test -vulkan" ABI_X86="(64)"
                                 ^^^^^^^^
    =dev-qt/qtgui-5.15.2*:5/5.15.2=[egl,libinput,-vulkan,X] required by (dev-qt/qtwayland-5.15.2-r17:5/5.15.2::gentoo, installed) USE="X -debug -test -vulkan" ABI_X86="(64)"
                                        ^^^^^^^^

x11-base/xorg-server:0

  (x11-base/xorg-server-21.1.3-r1:0/21.1.3::gentoo, ebuild scheduled for merge) USE="systemd xorg xvfb -debug -elogind -minimal (-selinux) -suid -test -udev -unwind -xcsecurity -xephyr -xnest" ABI_X86="(64)" conflicts with
    >=x11-base/xorg-server-21.1[udev] required by (x11-base/xorg-drivers-21.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" INPUT_DEVICES="libinput synaptics -elographics -evdev -joystick -vmmouse -void -wacom" VIDEO_CARDS="nouveau -amdgpu -ast -dummy -fbdev (-freedreno) (-geode) -glint -i915 -intel -mga -nv -nvidia (-omap) -qxl -r128 -radeon -radeonsi -siliconmotion (-tegra) (-vc4) -vesa -via -virtualbox -vmware"
                                ^^^^

sys-auth/pambase:0

  (sys-auth/pambase-20210201.1:0/0::gentoo, ebuild scheduled for merge) USE="nullok passwdqc sha512 systemd -caps -debug -elogind -gnome-keyring -homed -minimal -mktemp -pam_krb5 -pam_ssh -pwhistory -pwquality -securetty (-selinux)" ABI_X86="(64)" conflicts with
    sys-auth/pambase[elogind] required by (x11-base/xorg-server-21.1.3-r1:0/21.1.3::gentoo, installed) USE="elogind udev xorg -debug -minimal (-selinux) -suid -systemd -test -unwind -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)"
                     ^^^^^^^

1 Answer 1

0

The traces are just telling you that :

1/ You would like to install qtgui package with the libinput use flag unset while qtwayland needs qtgui as a dependency installed with the libinput use flag set.

To solve this conflict, you need to emerge qtgui with the libinput use flag set.

2/ You would like to install xorg-server package with the udev use flag unset while xorg-drivers needs xorg-server as a dependency installed with the udev use flag set when the xorg-drivers package is installed with the evdev use flag set.

To solve this conflict, you either need to emerge xorg-server with the udev use flag set, or re-emerge xorg-drivers with the evdev use flag unset. (The latter being definitely not recommended)

3/ You would like to install pambase package with the elogind use flag unset while xorg-server needs xorg-server as a dependency installed with the elogind use flag set when the xorg-server package is installed with the elogind use flag set.

To solve this conflict, you either need to emerge pambase with the elogind use flag set, or re-emerge xorg-server with the elogind use flag unset. (The latter being definitely not recommended)

Condidering that these use flags are global (used in many packages with the same meaning), I suggest you to prefer setting them definitely in your make.conf.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .