The KDE install on my PC includes IBus and the Japanese Anthy IME. In the IBus preference, I have enabled the Anthy IME. The IBus daemon is running and there is an IBus icon in the system tray, however, there does not appear to be any way of switching IMEs.

This is on PC-BSD 8.2.

What am I doing wrong here?


  • This question can be improved by adding information about the distro. Without it things may not get specific enough. – phunehehe Feb 6 '11 at 15:32

If you launch kde from xinit command , you could set the following environment variables in ~/.xinitrc ,

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

This will make all programs respect ibus. (If this don't work for you , modify startkde4 script directly , add the 3 lines to the top of it , after #!/bin/sh

And also a auto-start of ibus program , ibus-daemon -xd , set this in systemsettings , there's something named "Startup" , can't remember the exact name

  • I have all of that; yet in Firefox <kbd>Compose " o</kbd> correctly yields ö, but in Konsole it yields ̈́o — see this question. – gerrit Dec 15 '18 at 15:57

First, run ps -ef | grep ibus to check that the daemon is running with the correct option. There should be a process like ibus-daemon --xim.

Second, beware of the program you use to test iBus. For example, Kate (the KDE text editor) doesn't work with iBus (or at least not by default, you'll have to look more if you want that). I believe other KDE apps are like Kate as well, though I'm not sure. I use Chromium or Firefox to test iBus (click on the address bar and perform the key combination).

Third, (you may have already discovered that) iBus only functions properly once you have logged out and logged back in.

Update: a little searching revealed that there is ibus-qt for KDE applications.

  • Hi, Even if Firefox, ctrl-space (the configured shortcut) seems to do nothing. The ibus icon in the systray brings up the message "No input window" when clicked. – Leynos Feb 6 '11 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.