0

I have a fresh install of Arch Linux on a Lenovo laptop. I installed NetworkManager, but when I run nmcli d I only see the loopback device. The same result is shown when running ip link.
Both the NetworkManager and wpa_supplicant services are started and running. Currently I am not able to use Wifi and NetworkManager does not show the device.
Running lpsci -k yields

Network controller: Intel Corporation Ice Lake-LP PCH CNVI WiFi (Rev 30) Subsystem Intel Corporation Wi-fi 6 Kernel Modules iwlwifi

How do I get NetworkManager to recognize this device?

2
  • No "Kernel driver in use" line in the output of lspci suggests that the iwlwifi module isn't loaded. You may verify this with lsmod | grep iwlwifi, try loading it with modprobe iwlwifi (as root), search the system logs (journalctl) for messages relating to your card, which may give you a hint on why the driver is not loaded on boot, and double-check that the module is not blacklisted in /etc/modprobe.d/ or in the kernel command line.
    – fra-san
    Mar 16, 2022 at 22:39
  • There was nothing in /etc/modprobe.d/, lsmod | grep iwlwifi' yields ```iwlwifi 450560 0 cfg80211 1048576 1 iwlwifi``` There were no errors after running modprobe iwlwifi` journalctl shows Direct firmware load for iwlwifi failed with error -2 and no suitable firmware found Mar 17, 2022 at 13:42

1 Answer 1

1

The solution was to install the package linux-firmware and reboot the laptop Once that was done, I was able to see all available networks and utilize Wifi

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .