2

I am upgrading my machines periodically so I don't need to be reminded. I have configured Ubuntu 20.04 like this:

enter image description here

However I'm still getting this dialog every once in a while (maybe once a week):

enter image description here

Now, you may say it's no big deal because I can just dismiss it once a week. However, I'm using multiple VMs and regularly revert to checkpoints, meaning these machines end up checking for updates and notifying me A LOT. How to make it stop?

1 Answer 1

1

If you just want to disable the GUI popup then look in your session/startup settings. For example XFCE has a Session and Startup application and inside Application Autostart there is a Program called Update Notifier that can be disabled. Presumably other desktops have something similar to disable the notifier process when you log in.

If you want to kill the whole thing from the machine so you don't get notifications of any sort then:

apt remove update-notifier update-notifier-common update-manager

Note this may remove the "desktop" meta-package since the notifier/manager is a requirement.

2
  • 1
    OK, so the GUI I screenshotted in my Q is just a distraction / fake?
    – haelix
    Mar 19, 2022 at 12:14
  • @haelix Those settings don't affect normal notifications.
    – CR.
    Mar 19, 2022 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .