I've been using zsh with oh-my-zsh for several months now with vi commands. Frequently, the command line seems to "lock up" and become unresponsive to input. I chalked it up to some kind of bug, hit ctrl-c, and moved on.

I finally just figured out that I had somehow entered some special mode that activates the "j" and "k" keys to pull up prev/next commands. I still don't know what makes it activate and why it happens.

So now that I know something is happening and I don't know how, it's getting me annoyed. How do I avoid getting into this mode in the first place and how do I properly escape from it without hitting ctrl-c?

  • Ok, looks like the <esc> key is what activates this mode. How do I get out? and better, how do I turn this feature off so I don't get into it in the first place?
    – StevieD
    Mar 15, 2022 at 21:59
  • I don't appear to have any plugins that might enable this and I don't see anything in my config scripts either.
    – StevieD
    Mar 15, 2022 at 22:09
  • Ok, started radomly hiting different keys. The "s" key takes you out of this mode. Now how do I turn it off?
    – StevieD
    Mar 15, 2022 at 22:13
  • Looks like I need to unbind the ctrl key. No idea how to do that.
    – StevieD
    Mar 15, 2022 at 23:21
  • Sounds like you are triggering vi mode, except I can't reproduce this just by hitting esc.
    – user10489
    Mar 16, 2022 at 4:53


You must log in to answer this question.

Browse other questions tagged .