How can I disable Alt+Super+Left/Right from switching workspace in gnome-shell?

If I go into Keyboard settings there is no options

I am using latest GNOME version on Arch Linux. I am on Xorg.

  • 1
    Strange that there are no options in keyboard settingsm but then Gnome seems intent on removing everything remotely useful these days. Can you find the relevant setting in dconf-editor? Try searching for "workspace" for example.
    – terdon
    Mar 12, 2022 at 15:39
  • thanks @terdon for the tip; I have already watched there but sketchily... for story in the answer below
    – mattia.b89
    Mar 13, 2022 at 8:55

1 Answer 1


Solution can be achieved using graphical front-end dconf-editor or directly using coherent terminal commands:

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-left "['<Control><Alt>Left']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-right "['<Control><Alt>Right']"

In this way, I achieve my goal: disabling Alt+Super combinations, while leaving Ctrl+Alt ones functional

But... why is this issue so difficult to solve? Well, it is a gnome defect, since Gnome's Settings (Settings → Keyboard → Shortcut) does not show multiple shortcuts

in this case, by default, left workspace switching can be done with both: Super+Page Up or Super+Alt+Left or Control+Alt+Left but shortcut settings show only the first one! An issue [1] that has already been opened in the upstream bug-tracker, years ago.

[1] https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/620

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .