1

Out of nowhere, the left Windows/Meta key on my Corsair K70 RGB MK.2 just stopped working on my Manjaro KDE Plasma system.

The right one still works fine, opening the application launcher as it should. It also gets recognized by shortcut assignment as the “Meta” key.

The left one, however, doesn’t get recognized by anything anymore. It does send a signal, but in the Application Launcher Configuration it just looks… weird:

enter image description here (Note the garbled "name")

And setting it like that still won’t trigger the application launcher. It is as if the keyboard is just sending nonsense on that key all of a sudden.

Apps like https://keyboard-test.space/ or https://www.keyboardtester.com/ don’t recognize it, either, showing either “unrecognized” or nothing at all.

Obviously, I thought maybe the keyboard went kaputt, but I tried two other keyboards and those show the exact same behavior: Right Meta key works fine, left one not at all. Therefore I strongly suspect something in the system being the cause of this.

It can also not be related to any update, as none were installed in between it working fine and now being broken.

I have no idea how to even debug this problem further, so I'd be thankful for any ideas.

8
  • this says it can be "gaming button" and you have a gaming keyboard
    – Andra
    Mar 17 at 17:34
  • @Andra thanks, but there is no "gaming button" on a Corsair K70 RGB MK.2... at least I've never heard of that and see no button that would fit the bill.
    – TheSHEEEP
    Mar 17 at 18:47
  • three buttons above left?
    – Andra
    Mar 17 at 20:07
  • 1
    For what it's worth: I can confirm this. I have the exact same issue, since (at a guess) about the same time. Same key, same weird symbol, right meta works (I use the meta key + mouse for dragging and resizing my windows, and with the right hand on the mouse, it's annoying the left meta doesn't work). Differences are that I am on Ubuntu 20.04, and I use different keyboards (tested with GMMK Pro and Keychron Q3). So it might be a KDE Plasma keyboard interface issue.
    – 9769953
    May 11 at 18:26
  • 1
    No restart necessary for me. But if two independent people had this, roughly starting from the same date, and neither of them can't remember having set this option, then my best guess is a misconfiguration in an update of KDE/Kwin or whatever is responsible for this part of KDE.
    – 9769953
    May 13 at 18:16

1 Answer 1

1

I found a solution that worked for me:

Going from Settings:

-> Hardware section: Input Devices
-> Advanced tab
-> Position of Compose key
-> Turn off "Left Win" -> Apply.

It may require a restart.

I can't remember having ever set this option, so possibly it was accidentally set during an update, through a misconfiguration in that update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.