0

I'm on Arch Linux.

I once attempted to install aur/teams-for-linux with yay which installed nodejs-lts-gallium as a dependency. Since some things didn't work out and I found that teams could be used well in Chroimium, I stopped installing or uninstalled (I don't remember which) aur/teams-for-linux and replaced nodejs-lts-gallium with nodejs (sudo pacman -S nodejs). Now, when I run pacman -Qs nodejs, nodejs-lts-gallium isn't listed. However, I'm trying to run sudo pacman -Su but am getting nodejs-lts-gallium and nodejs are in conflict. Remove nodejs? [y/N].

How do I remove the nodejs-lts-gallium artifacts causing the conflict?

2
  • Have you tried pacman -R nodejs-lts-gallium ?
    – Fang
    Mar 7 at 6:19
  • @Fang Yes, I get error: target not found: nodejs-lts-gallium since it's not installed. Mar 7 at 7:30

1 Answer 1

1

After proceeding with the system upgrade, I found out that it was conflicting because nodejs-lts-gallium was being required by another package (bloodhound) which previously didn't require that version. Seems it wasn't a residual issue from teams-for-linux, just an unfortunate & confusing coincidence.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.