I have an ext4 mounted with the flags rw,suid,dev,exec,auto,user,async in /etc/fstab but running mount after mounting gives rw,nosuid,nodev,noexec,relatime,user.

How do I get it to mount exactly as written in /etc/fstab and (optionally) why is there such a difference?

I'm using Arch Linux.


1 Answer 1


You must put the exec, suid and dev options after the user option, because user implies noexec, nosuid and nodev.

See mount man page for details:


Allow an ordinary user to mount the filesystem. The name of the mounting user is written to the mtab file (or to the private libmount file in /run/mount on systems without a regular mtab) so that this same user can unmount the filesystem again.

This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .