2

I am now leaning towards a hardware problem, any advise is appreciated..

Gigabyte Z590 Vision D I9 11900K 3 Nvme SSD's - one Western Digital, one Sandisc, one Samsung RTX 3090 TPM Enabled > this device doesn't have a TPM chip, so it's emulated PTT Disabled/Enabled doesn't matter Secure boot currently disabled but enabled doesn't matter No sata discs, sata controller disabled, ethernet controller disabled

I've had ubuntu 20 working for a month or two now and I updated my bios, after the bios update ubuntu refuses to boot from the working install. Here's where it gets interesting... Live usb's don't work either!

I have tried ubuntu 22, 21, 20, 18, linux mint, and endeaveros. Endeaveros did manage to load once, but never again after that. I can get to the boot menu, but when I try to load a kernel/image it freezes.

If I try to launch recovery mode it hangs at "loading initlal ramdisk"

Relevant details:

I had windows 11 installed on first and third ssd. First was a real install, third was a virtual install. The first will boot windows but gives an error about "security settings changed, please reset pin" but then requires a network connection and claims there's no connection, even when the connection manager shows connected. Windows on the third ssd is how I'm typing this, which is very strange as this ssd was passed through to qemu and the install done virtually.

Windows usb installer boots fine.

Here's all of the changes from the bios:

Update CPU microcode version 0x34

Add Intel Adaptive Boost Technology support for Core i9-11900K & Core i9-11900KF processors

Add DDR4 5000/5066/5133/5333MHz support

Change default status of Intel® Platform Trust Technology (Intel® PTT) to Enabled for addressing basic Windows 11 requirements (https://support.microsoft.com/windows/1fd5a332-360d-4f46-a1e7-ae6b0c90645c)

Major vulnerabilities updates, customers are strongly encouraged to update to this release at the earliest. Credits to "Assaf Carlsbad and Itai Liba from SentinelOne"

Introduce capsule BIOS support starting this version. Customers will NOT be able to reverse to previous BIOS version due to major vulnerabilities concerns.

Improve the compatibility of non-K CPU with CXMT / Unic memory

Due to the capsule bios thing, I don't believe I can downgrade my bios, though I haven't tried

3
  • 1
    Do you remember all the changes you make to UEFI settings to install Ubuntu. Like change drives to AHCI, turn off Secure Boot, turn on allow full USB support & often several others. I have to keep a list as every UEFI update resets all those settings back to defaults. It may just be Secure boot, if you installed with Secure boot off, but check all your settings.
    – oldfred
    Commented Mar 1, 2022 at 16:48
  • My mobo only supports AHCI for sata disks, and the only disks I have are nvme's. The sata controller is completely disabled. I've tried toggling secure boot on/off with no difference, I may have to try the usb support. I am pretty sure I had secure boot on originally as I had windows 11 installed, but when I try to run ubuntu recovery with secure boot it freezes at "EFI STUB" vs "initial ramdisk" Commented Mar 1, 2022 at 17:26
  • See also: ubuntuforums.org/showthread.php?t=2472509 (Same user/question).
    – oldfred
    Commented Mar 1, 2022 at 18:46

4 Answers 4

1

You can use Q-Flush-Plus (by udisk -- an MBR FAT32 with GIGABYTE.bin) to downgrade.

I read the white paper of the Z590. The button positions are shown in the figure:

Z590 QFLUSH KEY

Z590 BIOS-UDISK-PORT

My Z590I VISION D has the same BIOS problem, customer service informd me that this method can be used. I managed to downgrade successfully and successfully installed Ubuntu.

2
  • 1
    It would be good to edit your answer and include the link to the source of the diagrams Commented Apr 26, 2022 at 6:14
  • Thank you for the suggestion - that's exactly what they told me to do as well, and I downgraded. Everything up until the most recent BIOS works. I explained this to them but they seemed to not care about linux support. Commented Apr 27, 2022 at 2:12
0

I have exactly the same issue on Asus Pro WS WRX80E-SAGE SE Wifi motherboard. After upgrading BIOS to version 1003, cannot boot Linux, nor Live USB - no matter what settings in BIOS. Choosing recovery mode from boot menu gets stuck on loading initial ramdisk. Trying to installing from Live USB, sometimes the screen appears, sometimes not. When it appears, I only see USB drive, and cannot choose SATA drive to put the installation on.

I never used Windows on this board. I didn't try with NVMe drive. BIOS downgrade normally not allowed by the tools. So I wrote to ASUS support, let's see about their answer..

3
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review
    – Archemar
    Commented Apr 27, 2022 at 7:18
  • But it helps others to see that it's not an isolated incident, but in fact a broader problem in newest AMI bios versions. Perhaps even a targeted attempt to put Linux at a disadvantage when it comes to bios support.
    – s0laria
    Commented Apr 30, 2022 at 16:38
  • Solved by downgrading to BIOS 0701. Everything works as before. The BIOS flashback port only accepts USB sticks with 32GB size or less, FAT32 partition, and partition table msdos. Hope it helps someone.
    – s0laria
    Commented May 9, 2022 at 9:29
0

Same issue here with the Asus Pro WS WRX80E-SAGE SE WiFi, which was solved by downgrading the BIOS from version 1003 to 0602 (BTW, you may opt for Rocky Linux instead of Ubuntu since Rocky does not kill the power of all USB ports with the latest BIOS 1003).

0

It works now! I updated my Gigabyte Z590 Vision D to firmware F8f, running Ubuntu 22.04.2 with Linux 5.19; all good now!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .