0

The problem is that when mixxx is running the audio output can't be switched to other audio from the computer and it also can't play the audio at the same time.

Depending on how Mixxx is used, this can be very cumbersome as you need to quit Mixxx to play other audio and restart it afterwards if you'd like to use it again.

For example, you can't take a pause of mixing music at home and watch a few videos in the browser or a movie in Kodi then go back to playing music (or just leave a set playing in the background). Another example is using Mixxx like a music player (an interactive one; especially if you use the auto-DJ feature for a playlist).

I'm running mixxx on Debian11/KDE with PulseAudio.

1 Answer 1

0

Mixxx prevents any other audio playing to prevent things like notification sounds or accidental audio output during live mixing (as well as lower latency).

The app launcher runs this command: pasuspender -- mixxx -platform xcb || mixxx -platform xcb. You can change the command of the launcher (the icon that you click) to mixxx -platform xcb or call that latter command in the console.

Once you have done so, you can then set "pulse" under Preferences->Sound Hardware->Output (for both Master and Headphones).
If you use PipeWire/Jack instead of PulseAudio select JACK there.

Then other audio can also play while mixxx is running.

Remember to use pasuspender when you do live mixing where you don't want any other audio output and low latency.

(source)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .