0

I might have screwed up my system pretty badly. I'm sorry if there is an obvious answer to this, still quite new to Linux, have only been running it for around 8 months. Currently running EndeavourOS with zsh.

I was trying to switch to pipewire from pulseaudio for support for LDAC. However, I forgot one key thing: I'm currently on school Wi-Fi (and will not be off it for a very long time), which blocks quite a bit of different package mirrors. Because I forgot that, I removed pulseaudio as well as pulseaudio-alsa pulseaudio-bluetooth pulseaudio-jack BEFORE I installed pipewire and pipewire-pulse. Big mistake. Once I tried to install that, it quickly returned an Error: 404 as it does every time the school firewall blocks a package download. A quick reboot confirmed my greatest fears: audio was completely screwed.

I've already spent around an hour looking for different solutions. Here is a small list of ones I tried in chronological order:

  • Just pacman -S pulseaudio. Result: Error: 404
  • Installing pulse-audio from source following this article. Result: pulseaudio installed, but audio still doesn't work at all, as don't any volume displays like on polybar. Ended up uninstalling from the same directory.
  • pacman -Sy pulseaudio. This time, pacman outputted something different, I suspect due to previously installing from source and not cleanly uninstalling:
➜  ~ sudo pacman -Sy pulseaudio        
resolving dependencies...
looking for conflicting packages...

Package (2)       Old Version  New Version  Net Change

extra/libpulse    15.0-1       15.0-4         0.00 MiB
extra/pulseaudio               15.0-4         5.81 MiB

Total Installed Size:  7.32 MiB
Net Upgrade Size:      5.82 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                           [------------------------------] 100%
(2/2) checking package integrity                         [------------------------------] 100%
(2/2) loading package files                              [------------------------------] 100%
(2/2) checking for file conflicts                        [------------------------------] 100%
error: failed to commit transaction (conflicting files)
pulseaudio: /usr/lib/systemd/user/pulseaudio-x11.service exists in filesystem
pulseaudio: /usr/lib/systemd/user/pulseaudio.service exists in filesystem
pulseaudio: /usr/lib/systemd/user/pulseaudio.socket exists in filesystem
pulseaudio: /usr/lib/udev/rules.d/90-pulseaudio.rules exists in filesystem
pulseaudio: /usr/share/bash-completion/completions/pacmd exists in filesystem
pulseaudio: /usr/share/bash-completion/completions/pasuspender exists in filesystem
Errors occurred, no packages were upgraded.

I honestly have no clue what to do now. Without audio I basically can't listen to music or watch any movies, both things which I do quite a bit every day. Hopefully the solution isn't just waiting until I get home, which means a 15 hour flight without anything to watch ;p Thanks in advance!

5
  • 1
    You could start by deleting the conflicting files... Feb 28, 2022 at 20:53
  • @mashuptwice is it safe to do so? they seem to be some kind of system services. sorry, i've broken my installs way too many times so i'm very careful about removing stuff now. Well, until I removed pulse. lol Edit: it is now showing as conflicting only the last two files.
    – Dion
    Feb 28, 2022 at 21:02
  • Obviously pacman complains that it can't install pulseaudio because these files already exist. This must mean that pacman tries to create these files. I see no problem in deleting them if they get recreated by pacman anyways. Feb 28, 2022 at 21:04
  • @mashuptwice it works!! thank you so much. sorry for a dumb question, still learning. have a nice day :)
    – Dion
    Feb 28, 2022 at 21:07
  • 1
    No problem, better safe than sorry! Feb 28, 2022 at 21:10

1 Answer 1

1

pacman is complaining that some files it tries to create are already existing.

pulseaudio: /usr/lib/systemd/user/pulseaudio-x11.service exists in filesystem

You need to delete them before reinstalling pulseaudio.

They seem to be a residue of the manual installation from source.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .