How can I disable wifi on Linux Mint 20? I use ethernet cables and have no use for wifi. There does not seem to be a GUI option to turn it off, so I would imagine it would be through the cmd.

Thank you.

2 Answers 2


Use nmcli:

nmcli radio wifi off

Radio Transmission Control Commands

wifi [ on | off ]
Show or set status of Wi-Fi in NetworkManager. If no arguments are 
supplied, Wi-Fi status is printed; on enables Wi-Fi; off disables Wi-Fi.
  • Not sure about Mint, but can you use lspci -v to identify the kernel module for the wifi adapter and then blacklist it in /etc/modprobe.d?
    – doneal24
    Commented Feb 28, 2022 at 20:27
  • 1
    I've tried a few different suggestions, including using nmcli another way. After turning it off and then on again ~twice it tends to freeze the system. Not sure if it's the new kernel or just a better method/use of the tool, this works great, thanks. Commented Mar 26 at 9:05

Depending on your setup and OS, there are a few options:

The most basic way: On a desktop PC and some laptops you can simply remove your WIFI-card if you don't need it. Just make sure you are comfortable with the idea of working on your PC and know what you are doing if attempting this option. If not, get professional help or try one of the other options.

Independent of your OS: Most Laptops offer WIFI-switches. Turning WIFI off this way will work similar to airplane mode on your phone. Usually, you will find these buttons somewhere between FN+F1 and FN+F12. Ethernet will keep working, but WIFI is turned off that way.

If you are using Mint 20 with a Cinnamon Desktop, there should be a toggle in your Internet Options. Go to your start menu -> network. You will find switches for different kinds of connections, including WIFI there

If none of those options work, you may actually have to turn it off in Terminal. I have, however, never done it that way so I can only hope someone else knows how to do it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .