I've been trying to dual-boot FreeBSD 8.1 with Mac OS X on my MacBook (5,2), but am having trouble trying to get the live cd to boot.

I reach the FreeBSD Boot Loader Screen with the options for boot, boot without ACPI etc.

However, I cannot select an option. I have tried with both the built in keyboard and a USB keyboard, but I do not think that that is the problem...

Previously I have tried dual booting Ubuntu, but had problems with the live CD also. During the boot process, the boot seemed to freeze, and the CD stopped spinning. I think it might be a similiar problem here. Soon after arriving at this screen, the CD stops spinning.

Thanks for any advice!

I've tried using both the amd64 disc1 iso image and the i386 disc1 image for FreeBSD 8.1

Further Boot Info

When booting, Mac's EFI allows me to choose to boot from the CD. The screen goes black, then the following appears:

CD Loader 1.2
Building the boot loader arguments
Looking up /BOOT/LOADER ... Found
Relocating the loader and the BTX
Starting the BTX Loader

BTX Loader 1.00 BTX version is 1.0.2
Consoles: internal video/keyboard
BIOS CD is cd0
BIOS drive C: is disk0
BIOS 639kB/1047552kB available memory

Loading /boot/defaults/loader.conf
/boot/kernel/kernel text=0x8d5503 data=0x129bf8+039f8 syms=[0x8 + 0xddbf8 + 0x8 + 0xca37e]

It then continues to the FreeBSD Boot Loader Screen, and freezes


Having tried both the amd64 and the i386 versions of FreeBSD 8.1, I've tried using the i386 version of FreeBSD 8.2.

It acts exactly the same as previous attempts, except that instead of freezing at the FreeBSD Boot Loader Screen (linked above), it prints some information to the screen as follows (below the boot loader screen, as it doesn't clear it first):

Copyright (c) 1992-2011 The FreeBSD Project
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of the FreeBSD Foundation.
FreeBSD 8.2-RELEASE#0: Fri Feb 18 02:24:46 UTC 2011
    [email protected]:/usr/obj/usr/src/GENERIC i386
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(™)2 Duo CPU  P7350 @ 2.00GHz (1990.43-MHz 686-class CPU)

    Origin = "GenuineIntel" Id = 0x1067a Family = 6 Model = 17 Stepping = 10
    AMD Features=0x20100000<NX,LM>
    AMD Features2=0x1<LAHF>
    TSC: P-state invariant
real memory = 2147483648 (2048 MB)
avail memory = 1789763584 (1706 MB)
ACPI APIC Table: <APPLE Apple00>
AP #1 (PHY# 1) failed!
panic y/n? [y]

Then it freezes, I cannot even enter y/n.

Again, thanks for any help.

  • can you show few last lines printed on screen before freezing? Also try to disable firewire in BIOS if you have one, I've seen panics in firewire driver during boot on some machines.
    – gelraen
    Commented Mar 11, 2011 at 22:36
  • I've added the info to the question. It doesn't mention firewire anywhere and I've never tried booting it with Firewire attached, or used Firewire ever. Macs don't have BIOS do they? The EFI boot loader doesn't seem to have any of those sorts of options.
    – Jasper
    Commented Mar 12, 2011 at 1:47
  • try i386 instead of amd64
    – gelraen
    Commented Mar 12, 2011 at 9:08
  • just tried, I have the same problem. Both the amd64 and the i386 versions work on my iMac, however, so the problem seems to be directly related to this MacBook
    – Jasper
    Commented Mar 12, 2011 at 12:17
  • 1
    before it starts. the spinning thing spins for a bit in the bottom left corner, then stops and a cursor appears at the top left and the entire thing seems to freeze
    – Jasper
    Commented Mar 12, 2011 at 23:36

4 Answers 4


Problem seems to be related to ACPI. Since you can not use keyboard while booting, I suggest to build custom kernel without ACPI (or even few with different configs), install system on flash drive and try to boot from it. If one of those kernels will boot correctly - just create partitions, format needed filesystems and dump|restore system from flash drive to hard disk.

  • I have a feeling that this is above my skill level... Also, what effect would having it run without ACPI have on the system?
    – Jasper
    Commented Mar 14, 2011 at 3:45
  • without ACPI system will not be able to control devices power state and shutdown correctly on pressing power button
    – gelraen
    Commented Mar 14, 2011 at 5:52
  • Will it effect battery life or the ability to put the computer to sleep?
    – Jasper
    Commented Mar 14, 2011 at 9:42
  • 1
    Yes, ACPI is used to control fans speed and periferal devices power consumption. You can try to use old power management interface - apm(4), but it will give much less control. Also, CPU scaling will be not affected, since it uses own interfaces, not related to ACPI.
    – gelraen
    Commented Mar 14, 2011 at 16:47
  • 1
    – gelraen
    Commented Mar 15, 2011 at 18:43

I have a 8.2 Installation running here on a MacBook 5,5 with ZFS root on a GPT partition (next to OSX, grml and Windows 7)

I had a similar error with older releases of FreeBSD, but that has been resolved at least for my hardware revision. jkim@ did an awesome Job and was very active in the freebsd.org forums: http://forums.freebsd.org/showthread.php?t=12289

This post is not necessarily very helpful, but could lead in the right direction. Feel free to ask me about any details.


If you will install your system in a flash drive, you don't need to build a new kernel. Just disable ACPI:


BTW: Did you try with option 2 of CD (To start without ACPI)?


EDIT: The previous link was reported as broken. As I think, this is the corresponding link now:



In the boot process you can hit a key different from [Enter] and access the loader(8). You can then disable ACPI with:

set hint.acpi.0.disabled=1 

and then boot with


But even with this my MacBookPro7,1 hangs on booting FreeBSD 10.2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .