0

I tried to clone my primary disk (dd to 2nd nvme disk), made a mistake (forgot to change the device name of the 2nd disk), booted from the 2nd disk and went into a recovery console (ramfs, limited commands).

That’s all ok. I just want to start over with the cloning, but the problem I’m having now is that as long as the 2nd disk is installed, the system automatically boots into it.

I checked and changed the boot device sequence in the BIOS back to what it was before, but that doesn’t do the trick. If I remove the 2nd disk, all is back to normal and the 1st disk boots. I can’t reformat the 2nd disk as it can’t be accessed without being present in the system during booting (don’t have a USB device that would accept an M2 SSD to attach it later).

Is there any setting that favours disk2 over disk1 when booting and where would this stored (again, I checked the BIOS boot sequence already). I’m at a loss with this problem. Any help is appreciated.

4
  • 1
    Sounds like you'll need to boot from a live CD/USB, then reformat the 2nd disk from there. Feb 25 at 0:27
  • 1
    A cloned disk will have the same UUID's (unless you change them). This makes booting potentially difficult. Feb 25 at 1:00
  • @fuzzydrawings spot on - that's what I did.
    – orange
    Feb 28 at 3:39
  • @JeremyBoden ok, that would be issue. I noticed that those UUIDs were showing up as identical when I booted from the live CD.
    – orange
    Feb 28 at 3:40

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.