1

Problem

I have one Ubuntu20 Desktop(Gnome) and I want it to be fully black and ideal. As reference, I have taken one Ubuntu20 Server and Installed openbox on it.

I hided the title bar of all the applications in OpenBox by editing the configurations in /etc/xdg/openbox/rc.xml and added

<application class="*">
      <decor>no</decor>
      <maximized>false</maximized>
    </application>

</applications>

So that it will hide the title-bar of all the applications. Also, I am able to achieve my demand. Image shown below as example. openbox

I want to perform the same on Gnome Desktop as well, but I don't know which config file to be edited for the same. Currently, my Gnome Looks like this gnome

Any help for the following is appreciated Thank you.

NOTE: I don't want to use only terminal, but will be using other applications like Firefox, chrome, VLC, etc. without title-bar

2
  • This sounds like you simply don't want Gnome, but just the gnome-session as session/hardware/connection… manager, with openbox as window manager! Commented Feb 21, 2022 at 12:01
  • No I just want to remove the title bar along with the title and close and minimize button. But in Gnome. Commented Feb 22, 2022 at 5:00

2 Answers 2

1

Well, after a few days of searching... I found the solution for my own question.

This might be not the correct way to solve it, but can be used to make things work.

  1. We need to make sure that Gnome works with Extention.
  2. We need to Install Unite Extention for that.
  3. Disable all the setting shown below in Unite Extention to get the desired output.

How to enable extensions

Install gnome-tweaks tool

sudo apt install gnome-tweaks

Then you can see your application on Show Application > Tweaks

Method 1 Use gnome-shell-extensions package [easiest and safest way]

Step 1 Install Gnome Shell Extention

sudo apt install gnome-shell-extensions

You’ll have to reboot your system (or maybe just restart GNOME Shell by pressing <ALT>+F2 and type r and Press Enter, I don’t remember it at this point). After that, start GNOME Tweaks, and you’ll find a few extensions installed. You can just toggle the button to start using an installed extension.

Step 2 Install Unite Extention

wget https://github.com/hardpixel/unite-shell/releases/download/v64/unite-shell-v64.zip 

For the latest release go to https://github.com/hardpixel/unite-shell/releases

And then Extract to extension folder of your home directory

uzip unite-shell-v64.zip -d ~/.local/share/gnome-shell/extensions

Then reboot or reload your Gnome shell by <ALT>+F2 then r and Enter

Method 2: Install GNOME Shell extensions from a web browser

GNOME project has an entire website dedicated to extensions. That’s not it. You can find, install, and manage your extensions on this website itself. No need even for GNOME Tweaks tool.

Website : https://extensions.gnome.org/

Step 1: Install browser add-on

You can simply click on the suggested add-on link by your web browser. You can install them from the link below as well:

For Google Chrome, Chromium, and Vivaldi: Chrome web store.

For Firefox: Mozilla Addons.

For Opera: Opera Addons

Step 2: Install native connector

Just installing browser add-on won’t help you. You’ll still see an error like:

“Although GNOME Shell integration extension is running, native host connector is not detected. Refer documentation for instructions about installing connector”

This is because you haven’t installed the host connector yet. To do that, use this command:

sudo apt install chrome-gnome-shell

Don’t worry about the ‘chrome’ prefix in the package name. It has nothing to do with Chrome. You don’t have to install a separate package for Firefox or Opera here.

Now head over to https://extensions.gnome.org/extension/1287/unite/ and Turn On the Extention.

Done It's Installed

Now go to extensions and open settings for Unite

enter image description here

and disable all settings like this enter image description here

& enter image description here

Now Close the settings and you are done!

Now Your decorators are hidden.

enter image description here

0

In the terminal run :

gsettings set org.gnome.desktop.wm.preferences button-layout 

This will get rid of all buttons, However, It won't remove the title bar.

1
  • Hi, Thanks but that was the solution I was looking for. Anyway after some RND, I was able to Achieve the solution for the same. I am attaching the solution on the same question with the link of question : stackoverflow.com/a/71908794/8813647 Commented Dec 5, 2022 at 6:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .