0

I'm trying to set up Samba in a linux SuSE enterprise 15 environment, however when I'm trying to map the linux share to windows a pop up for a log in is showing and everytime I log in it returns Access Denied.

Below is my smb.conf. From default smb, only the changes are:

  • added unix charset
  • force user
  • commented map to guest.
[global]
    workgroup = WORKGROUP
    passdb backend = tdbsam
    unix charset = UTF-8
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    #map to guest = Bad User
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = Yes
[homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = No
    read only = No
    inherit acls = Yes
[profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
[users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
[groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
[printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
[print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775
[testShare]
       #Shared Directory
       path = /home/oracle/messages
       #writable
       writable = yes
       #allow guest user
       guest ok = yes
       #guest only
       guest only = yes
       #fully accessed 
       create mode = 0777
       #fully accessed 
       directory mode = 0777
       #forceuser
       force user = HoeghSoaDev77

Also, I already created users in linux and Samba. Any suggestion?

> cat /ect/passwd

HoeghSoaDev77:x:xxxx:xxx::/home/HoeghSoaDev77:/bin/bash

> sudo pdbedit -L -v

[sudo] password for oracle:
---------------
Unix username:        HoeghSoaDev77

1 Answer 1

0

Would this be the 'Share' share ? The one that is 'guest only' and that will never work because you have turned off guest access in 'global'.

1
  • already uncomment the the map to guest. Still access is denied @Rowland Penny
    – user514348
    Feb 14, 2022 at 9:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .