9

I upgraded from Fedora 32 to Fedora 35 in last December. Lately I have found out that I am unable to play any videos on web browsers. The video loads but never starts. It's stuck at 00:00. If I move the video forward on the slider, the video skips to the correct frame, but still just sticks there. I get the message "If playback doesn't begin shortly, try restarting you device." in the browser. This happens at least on Firefox, Chrome and Midori.

Rebooting the system makes the problem go away, but it comes back shortly afterwards.

Playing locally stored MP4 files from my own filesystem on VLC is working OK.

What could be the reason for this?

When using fedy to install pulseaudio-module-bluetooth-freeworld-1.4-8.fc35.x86_64 this error shows up.

Error: Problem: problem with installed package pulseaudio-module-bluetooth-freeworld-1.4-8.fc35.x86_64 - package pulseaudio-module-bluetooth-freeworld-1.4-8.fc35.x86_64 conflicts with pulseaudio-module-bluetooth < 15.0-100 provided by pipewire-pulseaudio-0.3.38-1.fc35.x86_64

I tried sudo dnf remove pulseaudio, but it told me that this would also remove gnome-shells. How would I go about resolving the conflict?

5
  • 1
    did you try disabling hardware acceleration in your browsers' settings ? And can you tell more about the codecs in use for streaming ?
    – MC68020
    Feb 12, 2022 at 12:33
  • Do you have the mozilla-openh264 package installed?
    – jsbillings
    Feb 12, 2022 at 12:37
  • did you check out ask.fedoraproject.org/t/no-sound-after-upgrade/18964 ? I ask given your comment on the initial answer here.
    – ingli
    Feb 12, 2022 at 16:13
  • Based on the link provided by @ingli above, the problem might have been a conflict between pulseaudio, pipewire and wireplumber. I removed pulseaudio and rebooted the system, and the problem seems to have gone away. At least websites seem to be able to play video correctly. I haven't tried audio yet.
    – user53739
    Feb 13, 2022 at 2:43
  • see the following docs from fedora about plugins for playing video
    – xdavidliu
    Sep 15, 2022 at 0:09

7 Answers 7

6

RPM Fusion + sudo dnf install ffmpeg-libs - this will allow Firefox to play H.264/H.265 videos.

As for Google Chromium - I've no idea, I'm using Google Chrome and it supports H.264 out of the box.

4
  • there is no ffmpeg package, even if you enable non-free rpm fusion repo. There's ffmpeg-free, but that doesn't solve the problem. The actual packages you need to install are explained here.
    – xdavidliu
    Sep 15, 2022 at 0:09
  • 1
  • i stand corrected. Apparently the ffmpeg package is in the RPM fusion free repo.
    – xdavidliu
    Sep 15, 2022 at 14:57
  • 1
    I had to sudo dnf install ffmpeg-libs --allowerasing due to libswscale-free being already installed and conflicting with it. Thank you for the answer!
    – yuriploc
    May 11, 2023 at 14:34
5

Just chiming in that I had the same problem after a dnf system-upgrade from F34 to F35. It appears that the pulseaudio rpm isn't automatically swapped out for pipewire-pulseaudio, and I had to do sudo dnf install pipewire-pulseaudio --allowerasing to fix it.

3

I found the solution at pulseaudio makes videos in the browser frozen

When I updated to Fedora 34 I bumped into another problem, no sound after moving the video slider, so I switched from pipewire to pulseaudio and it worked again.

Today I updated to Fedora 35 and browser was unable to play. One can see the images while moving the slider, like the video is paused, but it won't play. The magic is that Fedora 35 has phased out pulseaudio and you need pipewire-pulseaudio to replace it.

$ sudo dnf install --allowerasing pipewire-pulseaudio

Then either reboot or:

$ systemctl --user start pipewire-pulse.service pipewire-pulse.socket
2

You need to install the codecs for Fedora. Fedora can't include it by default due to license problems.

Use fedy (aka Fedora utils):

# from RPM Fusion
sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

# or Install fedy copr repository
sudo dnf copr enable kwizart/fedy

# Install fedy
sudo dnf install fedy -y

Once installed open it, go to Utilities and install Multimedia Codecs

4
  • 1
    I tried this, but fedy reported an error: Error: Problem: problem with installed package pulseaudio-module-bluetooth-freeworld-1.4-8.fc35.x86_64 - package pulseaudio-module-bluetooth-freeworld-1.4-8.fc35.x86_64 conflicts with pulseaudio-module-bluetooth < 15.0-100 provided by pipewire-pulseaudio-0.3.38-1.fc35.x86_64 (the error is longer but it wouldn't fit in this comment) Apparently I have conflicting packages. I tried "sudo dnf remove pulseaudio" but it told me that this would also remove gnome-shell. How would I go about resolving the conflict?
    – user53739
    Feb 12, 2022 at 15:58
  • Then please add this reaction to your question @user53739.
    – ingli
    Feb 12, 2022 at 16:12
  • Typical example of RPM dependency hell (en.wikipedia.org/wiki/Dependency_hell) on Redhat based distributions. Debian derived ones don't suffer from this. Usually ;-).
    – JdeHaan
    Feb 26, 2022 at 9:27
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – JdeHaan
    Feb 26, 2022 at 9:28
0

I am runing 36 with KDE. I found a sound setting from the GUI configuration settings has a 'firefox' sound setting. That was disabled. Enabling that fixed my sound.

0

I just had the same problem. Mine was caused by me removing PulseAudio Volume Control. After installing Fedora 37 from scratch, my audio output is often resetting to an audio device that I don't use. In order to attend meetings or watch videos, I have to open up the sound settings and choose the correct audio output. It sucks.

I installed Pulse Audio Volume Control to try to mitigate it, but it just made things worse and more complicated. Removing the Pulse Audio Volume Control broke video playback as described in this post. Following the directions linked to by Joost fixed it... for now.

pulseaudio makes videos in the browser frozen

0

Here's what worked for me. First enable rpmfusion-free repo: from Fedora docs:

To enable the Free repository, use:

$ sudo dnf install \
https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

Then, you'll want to sudo dnf install either ffmpeg-libs or ffmpeg. If you try to do either, it will complain that it conflicts with libswscale-free and refuse to install, so I just did sudo dnf remove on libswscale-free, and then after installing ffmpeg, restarting firefox now instantly allows videos to work.

Note it must be ffmpeg or ffmpeg-libs, not ffmpeg-free (which does not require RPM fusion). Also, confusingly, ffmpeg and ffmpeg-libs are both in RPMFusion Free repo, not nonfree repo.

Also note that there's another Fedora doc page "Installing plugins for playing movies and music", but it didn't mention ffmpeg at all, so no clue what problem that page solves.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .