3

I have installed Debian 11 with both Gnome and KDE and soon I noticed that all fonts looks uglier under KDE than under Gnome even when running the same application and having the same font settings.

So, I took and zoomed some screenshots and the difference seems to be in different anti-aliasing.

Note that under both Gnome and KDE, my font settings is the same:

  • Hinting: Full
  • Anti-aliasing: Subpixel RGB

From the screenshots it's obvious that when I run Konsole under Gnome, the fonts are rendered correctly with the subpixel RGB AA, but when I run the same Konsole under KDE Plasma, the AA looks like to be grayscale only.

My question is: Does anyone also noticed that and is it possible to fix it somehow or is it some bug in KDE Plasma?

enter image description here

1 Answer 1

3

I think I've found where is the issue. The user config file, which controls the font rendering under KDE, is ~/.config/fontconfig/fonts.conf and it seems the KDE System Settings fails to set the property rgba which controls the RGB subpixel anti-aliasing. I guess it's a bug in KDE Plasma System Settings?

As a solution I used an utility qt5ct, which has an option to generate the fonts.conf file. But I guess you can just manually modify the file as well to add the rgba property.

Now, with the following fonts.conf, the fonts look like having the same RGB subpixel rendering under KDE like they have under Gnome.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintfull</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>rgb</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>false</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
    </match>
</fontconfig>

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .