I am trying to install RHEL 8 on an older server that had been running CentOs 7 and can't seem to do custom partitions even though it will install if I allow it to create the partitions. Every time I try to do a custom install I get the error message: /boot file system cannot be type lvmlv. raid0 may not have enough space.

I did an automatic install and logged in to see how the disk was partitioned:

> md126p1     1.1M   biosboot
> md126p2       1G   linux filesystem
> md126p3       1T   LVM

I tried repurposing the existing partitions created by the automatic install to the new installation. I tried deleting all partitions and repartitioning it using the same sizes. I even tried to use fdisk from a Slackware installation DVD to rewrite the partitons so that the RHEL installation wouldn't see the data from the old install. However, I got failed to write disklable. Operation not permitted.

I have 4 disks configured as a Raid 5 in the BIOS. And, as I said, it is an older server that does not support efi.

I can always do an automatic install and use lvm to create the additional partitions. But, I would like to figure out how to do this during the installation process.

2 Answers 2


After much rebooting/reinstalling the server, I think I figured it out. The problem appears to be that it is a BIOS based server rather then an EFI based server. I don't recall having this problem when I installed RHEL a year ago on an EFI server.

On an EFI server, the partition table is:

#         Start          End    Size  Type            Name
 1         2048      1230847    600M  EFI System      EFI System Partition
 2      1230848      1845247    300M  Microsoft basic 
 3      1845248   3904894975    1.8T  Linux LVM   

On the BIOS server it is:

Device         Start        End    Sectors  Size Type
/dev/md126p1     384       2687       2304  1.1M BIOS boot
/dev/md126p2    2688    2099711    2097024 1024M Linux filesystem
/dev/md126p3 2099712 5567512319 5565412608  2.6T Linux LVM

On the EFI server, all three partitions are mounted:

/dev/sda2 on /boot type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=winnt,errors=remount-ro)
<omitting the LVM partitions>

On the BIOS server only 2 of the partitions are mounted:

/dev/md126p2 on /boot type xfs (rw,relatime,seclabel,attr2,inode64,logbufs=8,logbsize=64k,sunit=128,swidth=384,noquota)
<omitting the LVM partitions>

In other words, EFI servers have 2 "boot" mount points: /boot & /boot/efi. While the BIOS only has one: /boot.

If you only create the /boot partition on the BIOS server, it will complain that you need a 'biosboot' partition. However, it will not let you create a partition without a mount point. The way I got around this was to create the /boot partition as xfs. Then create a /boot/efi partition also as an xfs. I then edited that partition by deleting the mount point & selecting "bios boot" for the file type.

Once I went through those contortions, I was able to create as many partitions on the LVM that I wanted.

  • 1
    /boot/efi is needed only on UEFI systems, on BIOS systems with GPT you always need the biosboot partition, you should be able to add it normally, you don't need mountpoint, you can select biosboot from the menu when adding it. Feb 10, 2022 at 20:08
  • @vojtech Thanks for the pointer. I didn't notice the "biosboot" option in all the times I was trying to create the partition. Interestingly, it still creates the /boot/efi/EFI/redhat subdirectory even though there is nothing in it. It just is located in the /boot partition.
    – Garnet
    Feb 10, 2022 at 20:17

/boot file system cannot be type lvmlv

This is a limitation configured in the Anaconda installer, /boot must be on a standard partition (or RAID), not on a logical volume.

I did an automatic install and logged in to see how the disk was partitioned:

This looks like a normal default partitioning with LVM on RAID: you got the BIOS boot partition (which is needed on GPT drives with BIOS), 1 GiB /boot and rest LVM physical volume which I assume has separate logical volumes for /, /home and swap.

I can tell from your description what storage layout are you trying to created, but I highly recommend reading through the RHEL installation guide which describes the storage configuration in detail. tl;dr version could be:

  • If you are not sure what to do, start with the Click here to create them automatically option. This will create the default partitioning.
  • Start adjusting the defaults. You'll see mountpoints (so /, /home etc.) on the left and after selecting one you can change the properties on the right.
  • You can change size, filesystem type, what disks will the mountpoint be on (for LVM you need to change this in the Volume Group section) etc.
  • You can add additional mountpoints/logical volumes if you have free space in the volume group (meaning you need to shrink the automatically created / or some other logical volume).
  • The automatic option will place mountpoints that needs to be on a partition (so /boot) on a partition. But if you manually place these on LVM, you can always change the type in the Device Type section.

enter image description here

If you have a previous installation you want to completely remove it manually, you can do that from the RHEL image too -- after the installer starts, just switch to console with Ctrl-Alt-F1, manually remove everything and then select Rescan Disks on the disk selection page in the GUI.

Also if you want to create the storage setup manually and just assign mountpoints manually to pre-created block devices, you can do that from the text based installer.

enter image description here

  • Thanks for the response. Most of your answer was superfluous since I have done many custom partitions in the past. The last 2 paragraphs were the informational ones. I tried the ctrl-alt-F1 method. Same error message. I will try the text method tomorrow.
    – Garnet
    Feb 9, 2022 at 22:00
  • Unfortuanetly, the text based installation automatically uses "automatic configuration" & won't let you change the partitions. The only way to partition the drive in text mode is to use a ks file.
    – Garnet
    Feb 10, 2022 at 19:52
  • Text based installation has the option "Assign mount points" which allows you to create the storage manually (using fdisk or MD/LVM tools) and then just assign existing devices to /, /boot and other mount points. Feb 10, 2022 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .