0

I am trying to figure out why doing a SRV record search on Ubuntu will not work without specifically including the FQDN on the end of the address. I have the domain name listed in my resolv.conf within the search parameter. The search works on Windows using nslookup without appending the FQDN though. I've been unable to find anything on the various forums. The query just returns NXDOMAIN unless I put the FQDN.

1 Answer 1

0

From the dig man page...

+[no]search Use [do not use] the search list defined by the searchlist or domain directive in resolv.conf (if any). The search list is not used by default.

which means it does not happen by default. So, dig +search -t srv <host>. It works here against other types, I just don't have a srv to test with.

nslookup seems a bit, iffy...

3
  • Yup, I tried +search but it doesn't make dig work either.
    – tczx3
    Commented Feb 8, 2022 at 20:03
  • Well, it works here. Does it work with other types? Perhaps you have an error in /etc/resolv.conf. Commented Feb 8, 2022 at 20:04
  • Yes, it works with other types. Normally, I don't specify the query type and those work as I'd expect appending the various suffixes in the list until a match is found. But with an SRV record it doesn't work. I also tried appending a . (period) to the end of the SRV lookup as the documentation states to end with a period if it is in a domain other than the current domain. Sadly that fails as well.
    – tczx3
    Commented Feb 9, 2022 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .