I downloaded the Fedora Workstation 35 iso and the Fedora media creation tool. I am using Fedora Workstation 35.1.2

After verifying and booting into the USB, when I click on the "Install to Hard Drive" icon, the mouse cursor spins for a while, goes back to normal and nothing happens. I have tried this using Rufus and a different ISO with the same result.

There are no logs that I can find

$ cat /tmp/anaconda.log 

And when launching Anaconda from the terminal it appears to hang forever

$ sudo anaconda
anaconda 35.22.2-3.rc35 for anaconda bluesky (pre-release) started.
# other text

EDIT: I found out that's not how you launch the installer, however liveinst hangs silently.

My specs are as follows and I am launching the USB via UEFI mode. Any ideas

Component Model
Motherboard Gigabyte X570 AORUS PRO WIFI AM4
Storage nVME SSD via M.2 unknown brand (Toshiba I think)


I have since tried a different a few things with no success:

  • Reset BIOS settings to factory

  • Disabled secure boot

  • Tried a different USB stick

  • Tried Rufus and Etcher

  • Tried "safe graphics mode"

  • tried nomodeset=0 in the launch options (I think that's the same as safe graphics mode?)

  • I installed Debian successfully but had broken graphics. I had to run apt install firmware-amd-graphics to get graphics working but all seemed well from there.

  • Manjaro loaded into the live distro the first time but when I attempted to install it hung on "78% configuring hardware". I rebooted and I was unable to load into the live distro again - getting stuck at the bootloader waterfall.

After reading this post I thought maybe I messed up the partition table on the hard drive and it's somehow screwing with all the distros (nvme SSD connected to an M.2 slot.)

So I took the hard drive out and launched into Fedora with no HDD in. liveinst still failed to launch

3 Answers 3


Issue was related to a weird state of one of my usb devices. I solved the issue by unplugging all my USB devices and putting them in different ports.

I figured this issue out because of steady ancient old Debian. I installed Debian 11 without issue I then upgraded the Kernel to 5.15 and suddenly udevu was hanging on shutdown.

I thought that it was odd and started fiddling around with the USB devices and after rearranging them, it shutdown without hanging.

I then realised that's probably why Manjaro hung when trying to detect my hardware and that it could be related to the silent failure of Fedora's live installer.

I then booted into Manjaro without issue, installed it without issue. I then put Fedora in and installed it without issue (except with how comically bad the installer is).

Older Linux kernel must have handled whatever weird state my USB devices were in a little more gracefully.

Wooo, got there in the end.

The problem device was my XBox one wireless receiver and the issue seems to only be present on new kernels


I can confirm that the above answer worked for me.

Anaconda seems to get into a tizz not using short-addressed USB ports (motherboard hard wired). Hubs and case ports seem to put it into a weird state not allowing the Install to Hard Drive functionality to work


I had the same issue with Fedora workstation 38. I rebooted my computer and chose "troubleshooting" from the Grub startup options. This leads to a menu where you can boot Fedora in safe mode, or graphics recovery mode. Once I started Fedora in safe mode, clicking on install to hard drive worked. The installation was smooth and quick on the overall.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .