0

I recently installed a fresh Ubuntu 20.04 image on my laptop while doing so i chose a full disk encrpytion using a password. (I think it is LUKS but I do not know how to verify this).

For some reason I can not decrypt the disk in the standard "decrypt screen" (I believe it is because of the keyboard layout which I chose to be Korean) but I can not verify this because I can only see asteriks (*) when typing in the passphrase.

After typing in the (apparently wrong) password I get the error message:

cryptsetup: ERROR: keystore-rpool: cryptsetup failed, bad password or options?

After three failed attempts the screen closes and a Terminal shows up with initramfs as prompt.

I tried figuring out which device is the encrypted device but standard commands such as df -h or lsblk don't work in this environment.

Because my keyboard seems to be working fine in this prompt, my questions is how to decrypt the encrypted disk and continue the normal boot process (presumably by mounting the device?)

I figured out that there is a command called cryptsetup but I am unsure how to use it and on which device. When I type cryptsetup --help the ouput is too big for my laptop screen and I can't pipe the output into a pager to read the manual.

I am unsure how to proceed, any suggestions are welcome.

Update: The only problem was me noting down a wrong password in my password manager. But I want to summarize all useful information on the way:

As suggested in the answer in: https://askubuntu.com/questions/1087230/ubuntu-18-04-cryptsetup-fails-to-recognize-passphrase-unlocking-from-live-usb

I used cryptsetup --debug luksDump /dev/<device> to find the encrypted device.

Also useful was knowing that I can switch between the password screen with F1 or Alt + Tab to look for other debug messages.

0

1 Answer 1

0

You can open and map the device with:

cryptsetup --verbose luksOpen /dev/sda1 SECRET

Where /dev/sda1 is your device and SECRET is the mapping

If you succeed to unlock your device, you need to mount it:

sudo mount /dev/mapper/SECRET /mnt

Maybe it would be more comfortable to plug in a live USB and try opening the device from another system...

Also, a link you may find helpful https://askubuntu.com/questions/1087230/ubuntu-18-04-cryptsetup-fails-to-recognize-passphrase-unlocking-from-live-usb

1
  • Thank you. Especially the added link helped me a lot. I updated my question now that the problem is solved. Feb 7 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.