1

I have freshly installed Rocky Linux 8.5 then yum upgrade and dnf upgrade.

Installed the kernel-headers and kernel-devel with gcc, etc. all following the instructions posted at several locations around the web.

Then tried to download and run the .bundle file from vmware.com to install Workstation Pro 16.2.1.

During the first attempt to run, the kernel modules vmmon and vmnet are supposed to compile, but fail to do so.

From several posts, it appears there was a back-port to fix a problem with a forthcoming kernel - but that fix fails with the current kernel now shipped with Rocky 8.5

I upgraded to kernel 5.16.4 following standard instructions for a kernel upgrade, but the same basic problems continue to manifest themselves.

Does anyone have instructions for creating ANY VERSION of vmware workstation on Rocky 8.5?

I ask for Rocky 8.5 instructions because Rocky 8.4 is no longer available for download from rockylinux.org

I am told this problem is also active on Red Hat Enterprises 8.5, but do not have access to a legal license for testing purposes thereon...

I find my situation to be a surprise, because vmware.com is a sponsor of Rocky Linux, and you would think someone in their QA group would have regression tested their code on the most recent general availability of Rocky?...

I don't have the necessary reputation to create the tag "rocky-linux"...

3
  • 1
    have a look there: github.com/mkubecek/vmware-host-modules/tree/workstation-16.2.1
    – A.B
    Feb 5, 2022 at 18:47
  • Does Rocky Linux have an LTS kernel you could try in the meantime? Feb 5, 2022 at 19:12
  • I tried a handful of replacement kernels before ending up on a satisfactory solution. The problem of not being able to compile the code was due to a back-port of a change to the code, and the ONLY workable solution was to use mr. mkubecek's posted solution.
    – jrvmedic
    May 24, 2022 at 22:14

3 Answers 3

4

This could solve your problem

git clone https://github.com/mkubecek/vmware-host-modules
cd vmware-host-modules
git checkout workstation-16.2.3
sudo make ; sudo make install
1
  • Thank you. You solved a problem I was stuck on for a couple of weeks
    – Shy
    Nov 15, 2023 at 1:45
1

Per the first comment to my question, Mr. "mkubecek" maintains fixes at github.com/mkubecek/vmware-host-modules for exactly the types of problems I was experiencing with building vmware's kernel modules vmmon.ko and vmnet.ko.

Read his posted "INSTALL" for the necessary steps to install and run the version of vmware workstation that you want.

Because i had those pages already bookmarked in my browser, so i was probably overemphasizing the "Rocky Linux" aspect of my question/problems, and didn't realize that Mr. mkubecek was maintaining a general solution that applied to more than one family of operating systems.

Hopefully this question will appear in the search-hit list of anyone in the future, who experiences the vmmon and vmnet build problems with RHEL 8.5 and the various CentOS replacements that are appearing on the network; i.e., Rocky Linux, AlmaLinux, etc.

1
  • This answer would be a bit more valuable to future readers if you included more of the steps you took get beyond the problem(s) in your Question. Thank you!
    – Jeff Schaller
    Feb 6, 2022 at 14:44
0

I had the same issue on kali linux. This fixed it for me:

$ sudo git clone \
  -b workstation-$( grep player.product.version /etc/vmware/config | sed '/.*\"\(.*\)\".*/ s//\1/g' ) \
  https://github.com/mkubecek/vmware-host-modules.git \
  /opt/vmware-host-modules/

$ cd /opt/vmware-host-modules/
$ sudo make
$ sudo make install

https://www.kali.org/docs/virtualization/install-vmware-host/#too-newer-kernel

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .