This was my previous, working configuration:

  • SSD1 - 256GB NVMe - Windows 10
  • SSD2 - 512GB SATA - Linux

This is my new configuration after an upgrade:

  • SSD1 - 1TB NVMe - Empty, unformatted
  • SSD2 - 512GB SATA - Linux

This is what I am trying to get:

  • SSD1 - 1TB NVMe - Linux (OS + home)
  • SSD2 - 512GB SATA - Data storage

The distribution I am using is Artix Linux (= Arch - systemd + OpenRC), but this should be irrelevant.

I created an USB stick installer (using Rufus and the distribution provided ISO), with GPT partition scheme / UEFI (non CSM).

When starting the installation, all I get is this message:

Welcome to GRUB!

error: unknown file system.
Entering rescue mode...
grub rescue>

I then reboot without the USB stick. The Linux on the SATA drive starts, and I get this output during boot:

procfs     [ * Mounting misc binary format filesystem ...
[ ok ]
binfmt     [ * Loading custom binary format handlers ...
[ ok ]
fsck       |fsck.fat 4.2 (2021-01-31)
fsck       |open: No such file or directory
fsck       |/dev/sda5: clean, 925153/22462464 files, 16723944/89840390 blocks
fsck       | * Filesystem couldn't be fixed
* rc: Aborting!
Starting default runlevel
fsck       | * Checking local filesystems ...
same output as before
agetty.tty4  | * 

Details form the BIOS:

UEFI BIOS Version        R0UET78W (1.58) 2020-11-17
UEFI Secure Boot         Off
USB UEFI BIOS Support    Enabled
Device Guard             Disabled
Boot priority order      1 USB, 2 Linux/SATA, 3 Windows/NVMe
UEFI/Legacy Boot         UEFI Only
   - CSM Support         Yes

The system information before the boot include:

NVMe Device: CT1000P5SSD8
Fixed Disk: Samsung SSD 850 EVO 500G

which should indicate there is no hardware issue.

Model: Lenovo ThinkPad E585 (Ryzen 2700)

Thank you for your help!

  • 1
    It seems you have grub installed somewhere UEFI or BIOS & system is booting that grub, not your live installer. Is live installer correct? You typically have to chose in UEFI boot menu f12 on many systems, check your manual and chose the UEFI:flashdrive menu item to boot flash drive in UEFI mode. If trying to boot in BIOS mode it may fail, but your would only get that same error if grub was in MBR of flash drive & you are booting in BIOS mode, not UEFI.
    – oldfred
    Feb 3, 2022 at 20:24

1 Answer 1


When creating the installation USB stick, I had two options: ISO mode or DD mode.

I picked ISO mode at first, and with this option I got stuck and wrote this question.

If I choose DD mode, the installation starts correctly.

This piece of information is available in the documentation, but I would suggest to make it more evident because of the impact it can have on the installation process and on the time wasted to find a solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .