3

I am triying to wake-on-line via SSH. I have done it once but after I suspend remote desktop via sudo systemctl suspend suspend, I can not do it again.

All steps I have done is from this link.

I think, my first problem is ethtool enp5s | grep wake-on returns Cannot get wake-on-lan settings: Operation not permitted. When I do it with sudo, it works:

Supports Wake-on: pumbg
    Wake-on: u

The u means u (unicast activity), and I think this is what i need for wake-on via SSH. Here is the problem: When I run systemctl suspend with wake-on: u configuration, system suspend and for a second and reopen. What should I do?

------------ UBUNTU VERSION ------------
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu Focal Fossa"
------------------------
------------ MINT VERSION ------------
No LSB modules are available.
Distributor ID: Linuxmint
Description:    Linux Mint 20
Release:    20
Codename:   ulyana

EDIT1: Interestingly, sudo pm-suspend works perfectly to suspend my computer (not reopen), but when I try to wake-on via ssh it is not wake-on. The weird thing is, it converts my Wake-on parameter from u to g.

1
  • The commands provided in the link start with a "#" meaning you are root. So, sudo is a possibility.
    – user4089
    May 19, 2022 at 12:26

2 Answers 2

1

and sorry for being so late.

There are known problems with pm-utils... see debian's wiki.

[...]

Troubleshooting WOL

[...] However, if you do want Wake On LAN on any of these events (other than "Magic Packet"), you may find conflicts with pm-utils. At the time of writing, scripts in this package will set the wake option for all relevant interface cards to "Magic Packet" only, (g). This will be a problem if you want your machine to wake "on-demand", when it receives traffic (u), for example. The issue and a fix is discussed below. [...]

and a solution consist to add a /etc/pm/power.d/disable_wol file containing no more than "exit 0" to overide the /usr/lib/pmutils/power.d/disable_wol file and stay persistent while updating packages.

Greetings

1
  • 1
    Thank you for your answer. I solve my problem with using pm-suspend.
    – bulmust
    May 21, 2022 at 14:58
0

I have a similar issue. My PC was configurated for WoWLAN. I used wakeonlan <MAC> command to wake up and systemctl suspend instead of pm-suspend.

In the case of pm-suspend my PC fans were starting every time I sent a wake package but sometimes I couldn't connect to the PC with ssh, ping its address and I had black screen when I attached the monitor.
The solution was to create /etc/systemd/system/wifi-resume.service with content:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target
[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service
[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

and activating the script sudo systemctl enable wifi-resume.service

I had to change network-manager.service in the script to snap.network-manager.networkmanager.service (my WoWLAN config). The correct name you can check in /etc/systemd/system/ directory. There is also suspend.service which explains why it works with systemctl suspend and doesn't work with pm-suspend

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .