3

on tty7 (graphical environment) nothing's wrong, I can enjoy the whole pixels of my screen which is the main thing.

But here's something a bit annoying, when I switch on terminals from 1 to 6, the visual space is shrunk to get into the upper left corner of my screen leaving the rest unused.

worth a million words : <img>pretty boring</img>

How can I fix that ?

update : here's an shot of my screen enter image description here

2

I ran into the same problem when using a laptop with an external display that had a higher native resolution than the laptop's built-in screen. The external display was running on its native resolution, but the tty only extended to an area matching the laptop's built-in screen.

I was able to solve this issue by issuing

fbset -a -g 1920 1080 1920 1080 32

The two instances of 1920 and 1080 match the 1920x1080 resolution of the external display. The 32 at the end is the color depth and I took this value from the output of fbset -i that I ran before the command above to investigate the current settings.

On modern Debian based distros with nvidia probably another way is to edit /etc/default/grub.

Furthermore, you can increase font size on HiDPI displays with

sudo dpkg-reconfigure console-setup  # Suggested Terminus, 16x32
sudo systemctl restart console-setup.service  # To apply immediately to all TTYs
  • In my case on Ubuntu 16.04 just installing fbset package overwrites (asking first) /etc/fb.modes (originally created by Retropie) and after reboot start working fullscreen, no need of fbset --all --geometry. – Pablo Bianchi Mar 4 '18 at 22:03
1

Only throwing out some suggestions. Install hwinfo and run:

  su -c 'hwinfo --framebuffer'
  # Or
  sudo hwinfo --framebuffer

  ...
  Mode 0x0343: 1400x1050 (+1408), 8 bits
  Mode 0x0345: 1400x1050 (+2816), 16 bits
  Mode 0x0346: 1400x1050 (+5632), 24 bits
  ...

Or use vbeinfo if you are in GRUB cli environment.

Update kernel entry in GRUB by

kernel /boot/vmlinuz ... vga=0x0346

Or in

/etc/default/grub

GRUB_GFXMODE=2560x1440x24
GRUB_GFXPAYLOAD_LINUX=keep
# And / or perhaps
GRUB_CMDLINE_LINUX="vga=0x038f"

Where x24 is bits from hwinfo aka depth - not needed, but...

http://www.gnu.org/software/grub/manual/html_node/Simple-configuration.html#Simple-configuration

# Can also try to use res instead of keep
GRUB_GFXPAYLOAD_LINUX=2560x1440

If it does not work then perhaps add vga=0x0abc to

GRUB_CMDLINE_LINUX_DEFAULT

Using proprietary nVidia drivers you might have to install v86d and add video option to GRUB_CMDLINE_LINUX_DEFAULT. Something in the lines of video=uvesafb:mode_option ...

You might also want to look at setupcon -f for font by configuration file perhaps at cat /etc/default/console-setup. man setupcon

  • thanks for your answer but it's not about the GRUB, the GRUB is fine. I was meaning when Ubuntu (in my case) starts, the graphical user interface is loaded on the tty7, but when I switch on another tty (non graphical) the problem occurs, see my post update, I've uploaded my screen. – vdegenne Mar 22 '13 at 20:33
  • 1
    @Oddant: Your system tries to load the best resolution etc. for consoles. You can use GRUB to modify this. E.g. increase resolution etc. GRUB uses it own gfxterm and can be nice as flowers or whiskey and your graphical environment be a mess. Same goes for console. Console uses either VGA text mode or frame buffer. What could be the case is that an invalid mode is used for console. Hence configure GRUB. And run update-grub. (Which is a stub for grub-mkconfig -o /boot/grub/grub.cfg) – Runium Mar 24 '13 at 23:49
  • @Oddant: As you have not stated which boot loader you use nor any other information like GPU or OS it is hard to give any more help. – Runium Mar 24 '13 at 23:51
  • thanks, my boot loader is the GNU GRUB version 1.99-21utbuntu3.1. I tried what you adviced me but nothing is changing – vdegenne Mar 25 '13 at 9:35
  • I had to add the new entries you told me in the /etc/default/grub as there were not specified originally. – vdegenne Mar 25 '13 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.