2

I have kali installed on my ssd and windows 10 installed on other hdd.

When I boot from ssd it shows grub menu which only have kali linux option and When I boot from hdd it directly boot windows 10.

So, I want to boot from only ssd, so I can select from grub menu which OS to boot. (want to add windows 10 option to grub menu)

SOLVED: I just detected the windows with os-prober and then reconfigured the grub file by grub-mkconfig. Thanks to Taqras.

1
  • Maybe add information about your partitions.
    – U. Windl
    Commented Jan 22, 2022 at 23:09

3 Answers 3

1

I'm not familiar with Kali, but basically you'd use install os-prober, mount your windows partition and re-generate the grub config.

The Arch wiki has a good explanation (note the special note about Windows): https://wiki.archlinux.org/title/Grub#Detecting_other_operating_systems

2
  • 1
    Note: if Windows was installed to boot in UEFI style and Kali was installed in legacy BIOS style, then it will be impossible to get both OSs in the same GRUB boot menu, as GRUB cannot switch between UEFI & legacy styles. The choice of boot style in Windows 10 is tied to the partitioning scheme: GPT partitioning requires UEFI boot, and classic MBR partitioning requires legacy BIOS-style boot.
    – telcoM
    Commented Jan 22, 2022 at 8:38
  • 1
    Also grub2 is turning off os-prober for some security reason. You can temporarily turn it back on in /etc/default/grub, run sudo update-grub and then turn os-prober off again. Better to copy boot stanza to 40_custom so you do not have to run os-prober at all.
    – oldfred
    Commented Jan 22, 2022 at 14:37
1

I had to do one step more before sudo-update grub, because I've got this message:

Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...

The solution was add the line

GRUB_DISABLE_OS_PROBER=false

after the last entry of /etc/default/grub (e.g. using sudo nano /etc/default/grub)

1
  • this step was needed on my machine as well
    – mossman
    Commented May 6 at 2:08
0

Note: I had to also run "sudo update-grub" to get this to work. Would not update the grub entries without it.

Steps were:

  1. sudo os-prober
  2. mount windows drive (double click on desktop)
  3. sudo grub-mkconfig
  4. sudo update-grub

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .