0

I'm running an Ubuntu based distro

Linux version 4.1.18-ipipe (ubuntu1604@ubuntu1604) (gcc version 4.9.3 (Ubuntu/Linaro 4.9.3-13ubuntu2) 

When this system boots up, rsyslogd is not running. So any C programs that call syslog(...) do not report any information. The simple fix to this is to SSH into the system and issue an rsyslogd on the terminal.

Is there a standard way to have this utility start up automatically?

2 Answers 2

0

Is the distribution systemd-based (ubuntu should be, but I am unfamiliar with this one)?

If that is so,

 systemctl enable rsyslog

ought to do the trick.

3
  • I'm somewhat inclined to think it's not systemd based, as syslog calls would be going to the journal if so. That or @Izzo isn't aware of the journal.
    – phemmer
    Jan 21 at 0:49
  • @phemmer I don't really understand the journal and how it interacts with syslog.. so i might be missing something on my end.
    – Izzo
    Jan 21 at 15:33
  • Looks like no systemctl on my machine: -bash: systemctl: command not found
    – Izzo
    Jan 21 at 15:35
0

That's really weird, as Linaro 4.9 is using systemd.

First check if the systemd package is

sudo dpkg -l | grep systemd

If not then install it by hands

sudo apt-get update
sudo apt-get install systemd

But if it does it might be damaged, so you may try to reinstall it

sudo apt-get install --reinstall systemd

After that you should be able to enable (autostart) rsyslog as LSerni stated:

systemctl enable rsyslog

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.