I've managed to get GIMP starting up completely off-screen somehow. Other applications are unaffected because they use click-to-place, but GIMP wants to just place it's own window.

What methods are there to get this window back on-screen?

I can see the application's "icon" in the twm "icon manager" and I can even see it minimised, but restore the window and it goes away off-screen. I can select Move from the "Super + middleclick-on-desktop" menu which calls f.move but that will only move the minimised icon.

The man page says I can set DontMoveOff in .twmrc but that's about moving, not an application starting itself at specific coordinates.

Running the command with -geometry is also a common solution, but gimp does not know this parameter.

$ gimp -geometry 1000x1000+10+10
Unknown option -geometry

In MS Windows, one can use + Spacebar to force a menu, one item being "move" which allows the window to be moved. But there doesn't appear to be a similar keypress in twm

Suggestions for wmctrl look positive, but twm seems to be too old to support this particular solution.

$ wmctrl -l
Cannot get client list properties. 
  • Sadly no - both those suggest wmctrl which can't work with TWM. Error returned is $ wmctrl -l /// Cannot get client list properties. /// (_NET_CLIENT_LIST or _WIN_CLIENT_LIST) Good idea, but twm might be too old.
    – Criggie
    Jan 20, 2022 at 0:09
  • @waltinator neat - that worked nicely! Thank you! The only small block was that GIMP's title bar says "GNU Image Manipultion Program" not "GIMP" and the search text has to be a substring of the title bar. Closing as dupe.
    – Criggie
    Jan 25, 2022 at 18:29

1 Answer 1


This answer is specific to GIMP, because it does not support standard X11 toolbox parameters like -geometry

  1. Run gimp with at least two filenames as parameters gimp image1.jpg image2.jpg
  2. The title spash screen is click-to-place.
  3. The first image will place itself, likely not visible on screen.
  4. Subsequent images are click-to-place, so do so.

Now you have access to a gimp window.

  1. Edit --> Preferences --> Window Management
  2. Reset Saved Window Positions will restore things to one combined Window, and set the other options as you see fit.
  3. OK and quit gimp. On restart, it should be more visible. If you want to return to multiple window mode, that's an option in the Windows menu.
  • This answer is specific to GIMP and is not a general purpose solution.
    – Criggie
    Jan 20, 2022 at 0:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.