1

Background:

Wifi was working for months. My computer semi froze (most of the programs I was running were killed and my file manager was glitching out) The termimal worked fine so I rebooted my pc from there (sudo reboot). Logging in took way waaaay longer than usual (30s+ more than usual) and I couldn't access internet anymore.

Updated kernel somewhere in december of last year. Have rebooted a few time since.

What have I tried:

  • phone on same wifi works fine
  • I rebooted my pc a couple of times
  • tried to connect using mobile hotspot. Pc connects to network but still no internet
  • ping -c 3 8.8.8.8 gives 3 packets transmitted, 0 received, 100% packet loss (same thing with mobile hotspot)

Relevant logs: Pastebin

lspci

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter [10ec:b822]
    DeviceName: Realtek RTL8822BE 802.11 bgn 1x1 WiFi + BT 4.2 Combo Adapter 
    Subsystem: Hewlett-Packard Company Realtek RTL8822BE 802.11ac 2 × 2 Wi-Fi + Bluetooth 4.2 Combo Adapter (MU-MIMO supported) [103c:831b]

iwconfig

wlo1      IEEE 802.11  ESSID:"WiFi-5.0"  
          Mode:Managed  Frequency:5.26 GHz  Access Point: <MAC 'WiFi-5.0' [AC1]>   
          Bit Rate=58.5 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=44/70  Signal level=-66 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:1   Missed beacon:0

TLDR: internet used to work, forced reboot, can still connect to wifi but no internet. Other devices can use the wifi

Edit:

(Had to type it by hand so there might be typos) Ifpconfig wlo1

Wlo1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 192.168.1.58 netmask 255.255.255.0 broadcast 192.168.1.255
Inet6 fe80::(etc) prefixlen 64 scopeid 0x20<link>
Ether c0::(etc) txqueuelen 1000 (ethernet)
RX packets 43239 bytes 639280 (6.0 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 29538 bytes 3386511 (3.1Mib)
TX errors 0 dropped 0 overruns 0 carriers 0 collisions 0

ip r | grep default (I think this is the router ip) pinging this gives me the same result as before. 100% package loss

Final edit: thank you so so much!!! It turns out my firewall rules somehow got messed up? Even though I hadn't touched them in years. I just turned them off completely.

3
  • Usually it's best to add the relevant information directly into the question. Links rot ... Jan 18, 2022 at 6:22
  • What does ifconfig wlo1 (or ip show) say about the wlan connection? Did you receive an ip address from the dhcp server? Can you ping the router?
    – Philippos
    Jan 18, 2022 at 6:31
  • I added ifconfig wlo1 output to the post. I'm not sure how to tell if I received a dhcp address? Jan 18, 2022 at 7:23

1 Answer 1

0

According to the pastebin, you have received an IP address and a default route from the DHCP server, and they look consistent.

You might have a faulty iptables/nftables software firewall configuration blocking your connections. To display iptables filter configuration, run iptables -L -vn as root; to display the newer nftables configuration, run nft list ruleset as root.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .