2

I am currently learning the basics of cybersecurity and I am trying to follow the following tutorial on ARP spoofing. I am using kali linux on a VirtualBox VM on my Windows pc to redirect my windows computer's gateway to my kali VM and I keep getting the "Couldn't arp for host" error. I have also tried redirecting my iPhone's gateway to kali in case redirecting my computer would not make sense from a VM but I run into the same problem.
My full process is using ipconfig on windows to get something like (it's in French):

Carte réseau sans fil Wi-Fi :  
   Suffixe DNS propre à la connexion. . . : epfl.ch  
   Adresse IPv6 de liaison locale. . . . .:  fe80::9c0c:82bd:c93d:a9ad%11  
   Adresse IPv4. . . . . . . . . . . . . .: 128.179.179.227  
   Masque de sous-réseau. . . . . . . . . : 255.255.248.0  
   Passerelle par défaut. . . . . . . . . : 128.179.176.1  

from which I deduce the commands I have to run on kali are:

echo 1 > /proc/sys/net/ipv4/ip_forward
arpspoof -i eth0 -t 128.179.179.227 128.179.176.1

My phone's IP is 128.179.199.89.
When I run ip a on kali, I get that my IP address is 10.0.2.15 and gateway is 10.0.2.2, I don't know if this difference is the reason I cannot make my command work. If anyone has any clue what I might be missing or what I should be calling instead, I'll be glad to hear your thoughts. Thank you!
https://www.youtube.com/watch?v=mchrDyBdMmc&t=421s

4
  • Thanks for the answer! I am using wireless indeed but I will try with a wired connection.I don't know how to make sure the VM is bridged to the same network but I will try and look into it.
    – Antoine
    Commented Jan 17, 2022 at 15:33
  • I was indeed, do you know how I can choose which bridge to select?
    – Antoine
    Commented Jan 17, 2022 at 15:40
  • 1
    Please avoid cross-posting, you are wasting people's time: superuser.com/questions/1699753/couldnt-arp-for-host-kali-linux
    – thecarpy
    Commented Jan 17, 2022 at 16:50
  • Sorry, I forgot to delete my first post when I learnt about this forum :/
    – Antoine
    Commented Jan 18, 2022 at 18:59

2 Answers 2

1

It seems there are a couple of issues to address

  • Your Kali VM is running with a NAT connection through your Host and to your target network. That must be changed to a Bridged connection so that your VM can get an IP address on the same network as your victim machine(s). This is controlled from the VitualBox management utility.

  • You're using a wireless interface so you may not be able to create a working Bridge connection. Remove this area of potential confusion by using a wired interface instead if at all possible

1

As roaima said, select bridged network, not NAT. Use a wired connection where possible.

You can see here how to set a VM to bridged networking:

https://wiki.dave.eu/index.php/VirtualBox_Network_Configuration

From that page:

Attaching an adapter to bridged netword adapter:

Changing the network interface to wired:

Select the network interface

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .