0

I have configured the chrony NTP server on rhel8 by using the commands chronyc sources -v and chronyc tracking to verify the time synchronization and it has succeeded. However, when I use the command w32tm /monitor /computers:XX.X.XX.XXX from Win10 to verify it, it gives me the following error ICMP: 0ms delay NTP: Error ERROR_TIMEOUT-No response from server within 1000 ms.

vi /etc/chrony.conf server XXX.XX.XX.220 iburst server XXX.XX.XX.219 iburst server XXX.XX.XX.218 iburst driftfile /var/lib/chrony/drift makestep 0.2 5 #rtcsync #hwtimestamp * #minsources 2

Allow NTP client access from local network.

#allow 192.168.0.0/16 allow XXX.XX.XX.0/24 #local stratum 10 #keyfile /etc/chrony.keys leapsectz right/UTC logdir /var/log/chrony log measurements statistics tracking leapsecmode slew maxslewrate 1000 smoothtime 400 0.001 leaponly bindaddress 127.0.0.1 logchange 0.5

but when I use the following command to check it,it can not get the clients information. [root@test etc]# chronyc clients Hostname NTP Drop Int IntL Last Cmd Drop Int Last

How can I fix this?

2 Answers 2

0

Per default chrony does not work as a server who can be used by everyone. You have to configure who is allowed to use your chrony.

vi /etc/chrony.conf

# Allow NTP client access from local network.
#allow 192.168/16
allow XX.X.XX.XXX/32
5
  • I have configured the ntp client :[allow XX.X.XX.XXX/32],how do i verfy ntp client can access to my chrony server.
    – Jade
    Jan 17, 2022 at 9:54
  • Restart the chronyd and give it a try.
    – ulrich17
    Jan 17, 2022 at 19:38
  • I have tried it ,but it still failed.
    – Jade
    Jan 18, 2022 at 4:21
  • Have you checked the firewall, selinux?
    – ulrich17
    Jan 18, 2022 at 7:56
  • yes, I checked it and the results is following: [root@test ~]# systemctl is-enabled firewalld disabled [root@test ~]# systemctl status firewalld ● firewalld.service - firewalld - dynamic firewall daemon Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor > Active: inactive (dead) Docs: man:firewalld(1) [1]+ 停止 systemctl status firewalld [root@test ~]# getenforce Disabled
    – Jade
    Jan 18, 2022 at 8:37
0

I know its old but you actually need on the server to:

# tell chrony to serve time
local
# allow all clients to pull time
allow 0.0.0.0/0

Make sure you also dont have some firewalld or something that can block the traffic

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .