0

I bought a used computer on Ebay last week and have been trying to install Arch Linux (my usual OS). For the most part it went smoothly, it boots fine without any issues and I can get a TTY for my user.

The last step remaining was launching i3wm. However, startx isn't working.

I looked at the Xorg.0.log file and there appears to be a segfault:

[   134.360] 
X.Org X Server 1.21.1.3
X Protocol Version 11, Revision 0
[   134.367] Current Operating System: Linux thinkpad-t480 5.16.0-arch1-1 #1 SMP PREEMPT Mon, 10 Jan 2022 20:11:47 +0000 x86_64
[   134.367] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=97a6e99b-b821-4676-9825-5f4b12fd9a64 rw loglevel=3 quiet cryptdevice=UUID=6f35e165-8b99-4b64-9b71-155ff64b0568:root root=/dev/mapper/root
[   134.372]  
[   134.373] Current version of pixman: 0.40.0
[   134.375]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   134.375] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   134.384] (==) Log file: "/home/keeyan/.local/share/xorg/Xorg.0.log", Time: Sat Jan 15 09:50:35 2022
[   134.387] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   134.389] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   134.390] (==) No Layout section.  Using the first Screen section.
[   134.390] (==) No screen section available. Using defaults.
[   134.390] (**) |-->Screen "Default Screen Section" (0)
[   134.390] (**) |   |-->Monitor "<default monitor>"
[   134.390] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   134.390] (==) Automatically adding devices
[   134.390] (==) Automatically enabling devices
[   134.390] (==) Automatically adding GPU devices
[   134.390] (==) Automatically binding GPU devices
[   134.390] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   134.392] (WW) The directory "/usr/share/fonts/misc" does not exist.
[   134.392]    Entry deleted from font path.
[   134.392] (WW) The directory "/usr/share/fonts/TTF" does not exist.
[   134.392]    Entry deleted from font path.
[   134.392] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[   134.392]    Entry deleted from font path.
[   134.392] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[   134.392]    Entry deleted from font path.
[   134.394] (==) FontPath set to:
    /usr/share/fonts/100dpi,
    /usr/share/fonts/75dpi
[   134.394] (==) ModulePath set to "/usr/lib/xorg/modules"
[   134.394] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   134.394] (II) Module ABI versions:
[   134.394]    X.Org ANSI C Emulation: 0.4
[   134.394]    X.Org Video Driver: 25.2
[   134.394]    X.Org XInput driver : 24.4
[   134.394]    X.Org Server Extension : 10.0
[   134.394] (++) using VT number 1

[   134.396] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[   134.397] (II) xfree86: Adding drm device (/dev/dri/card0)
[   134.397] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[   134.397] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[   134.401] (--) PCI:*(0@0:2:0) 8086:5917:17aa:225d rev 7, Mem @ 0xe7000000/16777216, 0xc0000000/268435456, I/O @ 0x0000e000/64, BIOS @ 0x????????/131072
[   134.401] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   134.401] (II) LoadModule: "glx"
[   134.401] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   134.408] (II) Module glx: vendor="X.Org Foundation"
[   134.408]    compiled for 1.21.1.3, module version = 1.0.0
[   134.408]    ABI class: X.Org Server Extension, version 10.0
[   134.408] (==) Matched intel as autoconfigured driver 0
[   134.408] (==) Matched modesetting as autoconfigured driver 1
[   134.408] (==) Matched fbdev as autoconfigured driver 2
[   134.408] (==) Matched vesa as autoconfigured driver 3
[   134.408] (==) Assigned the driver to the xf86ConfigLayout
[   134.408] (II) LoadModule: "intel"
[   134.408] (WW) Warning, couldn't open module intel
[   134.408] (EE) Failed to load module "intel" (module does not exist, 0)
[   134.408] (II) LoadModule: "modesetting"
[   134.408] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   134.414] (II) Module modesetting: vendor="X.Org Foundation"
[   134.414]    compiled for 1.21.1.3, module version = 1.21.1
[   134.414]    Module class: X.Org Video Driver
[   134.414]    ABI class: X.Org Video Driver, version 25.2
[   134.414] (II) LoadModule: "fbdev"
[   134.414] (WW) Warning, couldn't open module fbdev
[   134.414] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   134.414] (II) LoadModule: "vesa"
[   134.414] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   134.415] (II) Module vesa: vendor="X.Org Foundation"
[   134.415]    compiled for 1.21.1.1, module version = 2.5.0
[   134.415]    Module class: X.Org Video Driver
[   134.415]    ABI class: X.Org Video Driver, version 25.2
[   134.415] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   134.415] (II) VESA: driver for VESA chipsets: vesa
[   134.415] xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)
[   134.415] (II) modeset(0): using drv /dev/dri/card0
[   134.415] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   134.415] (II) modeset(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   134.415] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[   134.415] (==) modeset(0): RGB weight 888
[   134.415] (==) modeset(0): Default visual is TrueColor
[   134.415] (II) Loading sub module "glamoregl"
[   134.415] (II) LoadModule: "glamoregl"
[   134.415] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[   134.422] (II) Module glamoregl: vendor="X.Org Foundation"
[   134.422]    compiled for 1.21.1.3, module version = 1.0.1
[   134.422]    ABI class: X.Org ANSI C Emulation, version 0.4
[   134.531] (EE) 
[   134.531] (EE) Backtrace:
[   134.536] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x89) [0x55bf51a04049]
[   134.536] (EE) 1: /usr/lib/Xorg (0x55bf518b4000+0x15ae69) [0x55bf51a0ee69]
[   134.536] (EE) 2: /usr/lib/libpthread.so.0 (0x7fc5e6e05000+0x13870) [0x7fc5e6e18870]
[   134.537] (EE) 3: /usr/lib/libLLVM-13.so (0x7fc5dd6dd000+0x1acb683) [0x7fc5df1a8683]
[   134.538] (EE) 4: /usr/lib/libLLVM-13.so (0x7fc5dd6dd000+0x98d5f8) [0x7fc5de06a5f8]
[   134.538] (EE) 5: /lib64/ld-linux-x86-64.so.2 (0x7fc5e7282000+0xfe2e) [0x7fc5e7291e2e]
[   134.538] (EE) 6: /lib64/ld-linux-x86-64.so.2 (0x7fc5e7282000+0xff1c) [0x7fc5e7291f1c]
[   134.538] (EE) 7: /usr/lib/libc.so.6 (_dl_catch_exception+0xe5) [0x7fc5e6d6cd45]
[   134.538] (EE) 8: /lib64/ld-linux-x86-64.so.2 (0x7fc5e7282000+0x1420a) [0x7fc5e729620a]
[   134.538] (EE) 9: /usr/lib/libc.so.6 (_dl_catch_exception+0x88) [0x7fc5e6d6cce8]
[   134.538] (EE) 10: /lib64/ld-linux-x86-64.so.2 (0x7fc5e7282000+0x139bb) [0x7fc5e72959bb]
[   134.538] (EE) 11: /usr/lib/libdl.so.2 (0x7fc5e706d000+0x236c) [0x7fc5e706f36c]
[   134.538] (EE) 12: /usr/lib/libc.so.6 (_dl_catch_exception+0x88) [0x7fc5e6d6cce8]
[   134.538] (EE) 13: /usr/lib/libc.so.6 (_dl_catch_error+0x33) [0x7fc5e6d6cdb3]
[   134.538] (EE) 14: /usr/lib/libdl.so.2 (0x7fc5e706d000+0x2b99) [0x7fc5e706fb99]
[   134.538] (EE) 15: /usr/lib/libdl.so.2 (dlopen+0x48) [0x7fc5e706f3f8]
[   134.538] (EE) 16: /usr/lib/libgbm.so.1 (0x7fc5e6006000+0x66fc) [0x7fc5e600c6fc]
[   134.538] (EE) 17: /usr/lib/libgbm.so.1 (0x7fc5e6006000+0x85a0) [0x7fc5e600e5a0]
[   134.539] (EE) 18: /usr/lib/libgbm.so.1 (0x7fc5e6006000+0x871f) [0x7fc5e600e71f]
[   134.539] (EE) 19: /usr/lib/libgbm.so.1 (0x7fc5e6006000+0x8f1f) [0x7fc5e600ef1f]
[   134.539] (EE) 20: /usr/lib/libgbm.so.1 (0x7fc5e6006000+0x6885) [0x7fc5e600c885]
[   134.539] (EE) 21: /usr/lib/libgbm.so.1 (gbm_create_device+0x11a) [0x7fc5e600c9ca]
[   134.539] (EE) 22: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_init+0x67) [0x7fc5e5d6d697]
[   134.539] (EE) 23: /usr/lib/xorg/modules/drivers/modesetting_drv.so (0x7fc5e7264000+0x1096f) [0x7fc5e727496f]
[   134.539] (EE) 24: /usr/lib/Xorg (InitOutput+0x18b3) [0x55bf51a2b943]
[   134.539] (EE) 25: /usr/lib/Xorg (0x55bf518b4000+0x3c334) [0x55bf518f0334]
[   134.539] (EE) 26: /usr/lib/libc.so.6 (__libc_start_main+0xd5) [0x7fc5e6c5bb25]
[   134.539] (EE) 27: /usr/lib/Xorg (_start+0x2e) [0x55bf518f175e]
[   134.539] (EE) 
[   134.539] (EE) Segmentation fault at address 0x7fc9e3ec23b0
[   134.539] (EE) 
Fatal server error:
[   134.539] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   134.539] (EE) 
[   134.539] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   134.539] (EE) Please also check the log file at "/home/keeyan/.local/share/xorg/Xorg.0.log" for additional information.
[   134.540] (EE) 
[   134.565] (EE) Server terminated with error (1). Closing log file.

I decided to try with xf86-video-intel which sometimes helps and sometimes hurts. Once installed it went a little bit better. i3 launched fine, but now any GUI apps that I try to launch coredump (e.g. nm-applet, alacritty, brave etc.):

Jan 15 10:23:05 thinkpad-t480 systemd[1]: Started Process Core Dump (PID 3678/UID 0).
Jan 15 10:23:05 thinkpad-t480 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@2-3678-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 15 10:23:05 thinkpad-t480 kernel: audit: type=1130 audit(1642242185.889:130): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@2-3678-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 15 10:23:06 thinkpad-t480 systemd-coredump[3679]: Process 3677 (alacritty) of user 1000 dumped core.
                                                      
                                                      Module linux-vdso.so.1 with build-id 3b23eb9fafd9a6683da8f2a15381914a95d54b1e
                                                      Module libicudata.so.70 with build-id e1dcc2a88cfaafed882d09c90c668af0eed4efed
                                                      Module liblzma.so.5 with build-id 8b615460aa230708c5183f16bede67aa0437d95e
                                                      Module libicuuc.so.70 with build-id 2e245c2bf12f95fd8ab79b3a4be99524677cbd70
                                                      Module libxml2.so.2 with build-id b710b880b0d4e9c93554fa632129db44c20632cd
                                                      Module libncursesw.so.6 with build-id 859adb8b03a5655151b4da104bc4b326a0d4bc8c
                                                      Module libedit.so.0 with build-id 4b0babfcad161c2ad0af6e59e2493258db23a331
                                                      Module libffi.so.8 with build-id f90d8b734f6de9b25faedb8cbfab7054dafc0a42
                                                      Module libvulkan.so.1 with build-id 0c8486d8689e18bd837da80fe4d17664a248bc10
                                                      Module libdrm_nouveau.so.2 with build-id ee16fa6a4d0bd08f5448cfc046ccb76b49aaa8a3
                                                      Module libdrm_amdgpu.so.1 with build-id 30d019987d514b23115b47d6b47c1e45c18fdbaf
                                                      Module libelf.so.1 with build-id a4fb077dcec6ee26a5fab1fa10c59bd03b1078e4
                                                      Module libdrm_radeon.so.1 with build-id 5d1615e0467d0a34a5a82cbd4ebc84851e116307
                                                      Module libsensors.so.5 with build-id dc8b2c1c0d8525411aca188ea3cc3fb86d381d30
                                                      Module libzstd.so.1 with build-id 6214183688018e3fba6d66db10c2c8d0b45e0578
                                                      Module libLLVM-13.so with build-id 82982c299d46219d0eab8ee9cb8bb7365483453b
                                                      Module iris_dri.so with build-id ebdb09c64ad01a77f899d04accb3d2e414fe5cf1
                                                      Module libstdc++.so.6 with build-id 9b5eeeb149bf3c4efe787fb398b44f00507aec87
                                                      Module libxcb-xfixes.so.0 with build-id a6b197ace5b9b59f913f5969eb419a88d1194f47
                                                      Module libxshmfence.so.1 with build-id 8876d9ccf620858795724ca24b9e567585a77cec
                                                      Module libxcb-sync.so.1 with build-id dda14591103b01b1311906053bf1ca9e82ade35c
                                                      Module libxcb-present.so.0 with build-id 68f5465258750e2397b1333b3ffc01ee33caa4e1
                                                      Module libxcb-dri3.so.0 with build-id 9407a2480e09dc5a1dd9d9a0652fa8d32b328c91
                                                      Module libxcb-shm.so.0 with build-id fb797f299a446f559a95afcc168227482cc800d1
                                                      Module libXxf86vm.so.1 with build-id 01e8243d0c6c971fa9e743e6e53d606b1cb76f6e
                                                      Module libxcb-dri2.so.0 with build-id 2dd6e65129a809dab828a1d26215a3f7a363fcc8
                                                      Module libxcb-glx.so.0 with build-id 8ad115382ad874165523dc5b4488c99d73bbc3c4
                                                      Module libdrm.so.2 with build-id 457a1a1bd25f1d5541a10d3f16c5dc1440d77c7d
                                                      Module libglapi.so.0 with build-id 9331aed5060062bcfafd463d36506312fab59549
                                                      Module libGLX_mesa.so.0 with build-id 76cdb170e96b9ad2d09c67051436088c007f4b7b
                                                      Module libGLX.so.0 with build-id 2a08836c6e6126ce9ff4496b6aacaf29ae9b4e7b
                                                      Module libGLdispatch.so.0 with build-id 501765b3a78d668860fa54229b18107473aeda4c
                                                      Module libGL.so.1 with build-id 912ac4f37a9fa2d5abcf7a9088c9983cfe46f12a
                                                      Module libX11-xcb.so.1 with build-id 0db4f94d8ae31b8dc9a83f825a9171656f1e532c
                                                      Module libXi.so.6 with build-id 16603be937a02a7e61b0b0395d064be7efd86f49
                                                      Module libXext.so.6 with build-id d70f24beb4fad748d6becffdcc13e51be0a2ebfa
                                                      Module libXrandr.so.2.2.0 with build-id d4e869b5c72541e1de8f96b456248987ea52d51b
                                                      Module libXfixes.so.3 with build-id 0a05c7e8714522bfbdd7c0027c3e2a94965664b0
                                                      Module libXrender.so.1 with build-id 97e0b9ab6ba96ebc86527cc2b3c3078aad8616b3
                                                      Module libXcursor.so.1 with build-id eb6315bcd7526aaf51b0a1307efdc587cea0a152
                                                      Module libX11.so.6 with build-id 5ba5798d193c0065014b8c6252a0678671c8d478
                                                      Module libpcre.so.1 with build-id 845483dd0acba86de9f0313102bebbaf3ce52767
                                                      Module libbrotlicommon.so.1 with build-id a4ba3f4b4571c8272343b621da812a6e24a202a7
                                                      Module libglib-2.0.so.0 with build-id 220436a4e27f39372710df014d2517c0387eefa4
                                                      Module libgraphite2.so.3 with build-id 47761dc11e553f519cde97ed9ee985be12ccdae2
                                                      Module ld-linux-x86-64.so.2 with build-id 040cc3dd10461562f177df39e3be2f3704258c3c
                                                      Module libXdmcp.so.6 with build-id 8ca0792d23c8b8b4c0864297512349292bea5955
                                                      Module libXau.so.6 with build-id 1c67764663e07bec24d8951e5fd93f4d165979ff
                                                      Module libexpat.so.1 with build-id 16023a53e7b5bbdff92bd0bf2eebd36f9b5b879f
                                                      Module libbrotlidec.so.1 with build-id 45defc036e918e0140a72f1fbce6e7692d38241d
                                                      Module libharfbuzz.so.0 with build-id 1d9dee49dd99162c3f83eb3259c3c88c6b4cd7fe
                                                      Module libpng16.so.16 with build-id 2dc0bce07f199bf983c07a05fb95a6f4af83a9b3
                                                      Module libbz2.so.1.0 with build-id 919597c477c9b2cb9cdbb7745ed6494ac0e6da60
                                                      Module libz.so.1 with build-id 0c1459c56513efd5d53eb3868290e9afee6a6a26
                                                      Module libc.so.6 with build-id 4b406737057708c0e4c642345a703c47a61c73dc
                                                      Module libm.so.6 with build-id 2b8fd1f869ecab4e0b55e92f2f151897f6818acf
                                                      Module libpthread.so.0 with build-id 07c8f95b4f3251d08550217ad8a1f31066229996
                                                      Module librt.so.1 with build-id 75484da2d6f1515189eefa076e0a40328834cd16
                                                      Module libutil.so.1 with build-id af6d8200064ee6e6a01252884d166b44f0a6121b
                                                      Module libgcc_s.so.1 with build-id 7f8508bb914546ada778809b64b99d234337d835
                                                      Module libdl.so.2 with build-id 5abc547e7b0949f89f3c0e21ab0c8331a7440a8a
                                                      Module libxcb.so.1 with build-id 0d1ef11740a5daad2ee331e812a51aa6574af222
                                                      Module libfontconfig.so.1 with build-id 1103a641395c7d3b42e49b793d3a9ea927c77bf6
                                                      Module libfreetype.so.6 with build-id 26c5f833068ff72660d1975cbc2074c3eb47fad8
                                                      Module alacritty with build-id 1e625a961519ee171ca24b2cbf8a2f2901d9132e
                                                      Stack trace of thread 3677:
                                                      #0  0x00007fd3e11c0683 n/a (libLLVM-13.so + 0x1acb683)
                                                      #1  0x00007fd3e00825f8 _ZN4llvm3orc13MachOPlatform14notifyRemovingERNS0_15ResourceTrackerE (libLLVM-13.so + 0x98d5f8)
                                                      #2  0x00007fd3e9052e2e call_init (ld-linux-x86-64.so.2 + 0xfe2e)
                                                      #3  0x00007fd3e9052f1c _dl_init (ld-linux-x86-64.so.2 + 0xff1c)
                                                      #4  0x00007fd3e8cb0d45 _dl_catch_exception (libc.so.6 + 0x138d45)
                                                      #5  0x00007fd3e905720a dl_open_worker (ld-linux-x86-64.so.2 + 0x1420a)
                                                      #6  0x00007fd3e8cb0ce8 _dl_catch_exception (libc.so.6 + 0x138ce8)
                                                      #7  0x00007fd3e90569bb _dl_open (ld-linux-x86-64.so.2 + 0x139bb)
                                                      #8  0x00007fd3e8ed836c n/a (libdl.so.2 + 0x236c)
                                                      #9  0x00007fd3e8cb0ce8 _dl_catch_exception (libc.so.6 + 0x138ce8)
                                                      #10 0x00007fd3e8cb0db3 _dl_catch_error (libc.so.6 + 0x138db3)
                                                      #11 0x00007fd3e8ed8b99 n/a (libdl.so.2 + 0x2b99)
                                                      #12 0x00007fd3e8ed83f8 dlopen (libdl.so.2 + 0x23f8)
                                                      #13 0x00007fd3e7ed8208 n/a (libGLX_mesa.so.0 + 0x51208)
                                                      #14 0x00007fd3e7edabc9 n/a (libGLX_mesa.so.0 + 0x53bc9)
                                                      #15 0x00007fd3e7edbb5e n/a (libGLX_mesa.so.0 + 0x54b5e)
                                                      #16 0x00007fd3e7ebe141 n/a (libGLX_mesa.so.0 + 0x37141)
                                                      #17 0x00007fd3e7ebe954 n/a (libGLX_mesa.so.0 + 0x37954)
                                                      #18 0x00007fd3e7ebed13 n/a (libGLX_mesa.so.0 + 0x37d13)
                                                      #19 0x000055dcf1a4d59f n/a (alacritty + 0xa859f)
                                                      #20 0x000055dcf1b11b71 n/a (alacritty + 0x16cb71)
                                                      #21 0x000055dcf1a5c9a6 n/a (alacritty + 0xb79a6)
                                                      #22 0x000055dcf1a589b9 n/a (alacritty + 0xb39b9)
                                                      #23 0x000055dcf1a3264b n/a (alacritty + 0x8d64b)
                                                      #24 0x000055dcf1b58f83 n/a (alacritty + 0x1b3f83)
                                                      #25 0x000055dcf1a40689 n/a (alacritty + 0x9b689)
                                                      #26 0x00007fd3e8b9fb25 __libc_start_main (libc.so.6 + 0x27b25)
                                                      #27 0x000055dcf1a1011e n/a (alacritty + 0x6b11e)
                                                      ELF object binary architecture: AMD x86-64
Jan 15 10:23:06 thinkpad-t480 systemd[1]: systemd-coredump@2-3678-0.service: Deactivated successfully.
Jan 15 10:23:06 thinkpad-t480 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@2-3678-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 15 10:23:06 thinkpad-t480 kernel: audit: type=1131 audit(1642242186.009:131): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@2-3678-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 15 10:23:06 thinkpad-t480 audit: BPF prog-id=0 op=UNLOAD
Jan 15 10:23:06 thinkpad-t480 audit: BPF prog-id=0 op=UNLOAD
Jan 15 10:23:06 thinkpad-t480 audit: BPF prog-id=0 op=UNLOAD
Jan 15 10:23:06 thinkpad-t480 kernel: audit: type=1334 audit(1642242186.139:132): prog-id=0 op=UNLOAD
Jan 15 10:23:06 thinkpad-t480 kernel: audit: type=1334 audit(1642242186.139:133): prog-id=0 op=UNLOAD
Jan 15 10:23:06 thinkpad-t480 kernel: audit: type=1334 audit(1642242186.139:134): prog-id=0 op=UNLOAD

I also tried the following xorg.conf (as well as a few different alterations, like disabling Accel) with and without xf86-video-intel, but it doesn't seem to help (found at https://bbs.archlinux.org/viewtopic.php?id=208252):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"     "uxa"
EndSection

I tried booting a Linux Mint live USB and everything works fine. I can launch the desktop environment, watch videos etc. without any issues. It also came pre-installed with Windows and Windows worked fine as well. Since I bought the PC second hand I ran all the bios diagnostics (for unrelated reasons) just to check that it's all okay and all tests passed as well. I also tried switching to linux-lts and that made no difference either :(

I've spent quite some time looking into this issue and haven't been able to figure it out. Any help is really appreciated :)

UPDATE: After reinstalling Arch from scratch, X seems to be working fine. I haven't ran any of my setup scripts yet (they install packages I use, configure things etc.), so there is likely something wrong there that broke it. I'm going to start manually running parts of that script until I figure out what part broke X, and once I do I'll post an answer here explaining what caused it.

4
  • Does Windows work in this laptop? Jan 16 at 20:40
  • @ArtemS.Tashkinov, yes. As I said " It also came pre-installed with Windows and Windows worked fine as well. " Also live booting Mint worked too. I'm currently watching videos off of it on the TV booted from the USB and it's working fine.
    – KNejad
    Jan 16 at 21:39
  • Get rid of glamoregl, that only works for AMD, and that should stop the segfault. The choice of the right intel driver is a bit complicated, lspci should help with determining what chipset you actually have. glxinfo will tell you if OpenGL acceleration (what you need for alacritty etc.) works.
    – dirkt
    Jan 16 at 21:49
  • Thanks @dirkt, how would I go about removing glamoregl since it's built into the xorg-server package now? Also I can't find anywhere saying it's only for AMD.
    – KNejad
    Jan 17 at 9:35

3 Answers 3

0

Does your laptop have an nvidia GPU? I'm using a Lenovo L340 and here's my neofetch:

Neofetch

So I have to add following kernel parameter to /etc/default/grub (to disable nouveau):

nouveau.modeset=0 i915.enable_psr=0

Now my /etc/default/grub looks like

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Center"
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet nouveau.modeset=0 i915.enable_psr=0"
GRUB_CMDLINE_LINUX=""

Btw if you want to enhance your Xorg experience (you're on UHD620 just like me so you can just copy and paste these configs), try this:

Section "Module"
  Load "dri3"
EndSection
Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option      "DRI"   "3"
  Option "TripleBuffer" "true"
  Option "TearFree" "true"
EndSection

which fixed my glitch and tear of screen.

0

I tried reintalling Arch Linux and it installed fine and Xorg would launch seemingly without any issues. But after playing around for a bit I noticed many programs would segfault for no apparent reason. Some stuff failed to compile outside of Xorg as well.

This made me suspect it might be hardware related. After asking a question on SuperUser I was advised to run Memtest86. I ran the program and it complained about too many errors.

So it seems in this case, the issue was caused by an issue with the physical RAM sticks, not anything to do with software.

-1

Can you give a try with a Manjaro iso and see what's under the hood if it works? (I have a L590 with the i5-8265u - and and a spectrex360 i7-8565u - will update as soon as I get my hands on it).

From my limited experience running intel vesa driver was a no-go. For this CPU imo, hardware gpu support, while quite good, seems not totally working (running cloud gaming app cannot enable hardware h.264 for some reason) troubleshooting stuff

3
  • Hi @Alsushi, I tried booting from Manjaro and it also works fine. I also tried playing around with the vesa driver (uninstalling re-installing etc.) but it didn't help. I looked through the Xorg logs on Mint and all the configs to see if I can install the missing packages but it didn't lead anywhere. I couldn't work out from the logs what I'd need to install. I assume the case will be the same on Manjaro but I'll try that too this evening.
    – KNejad
    Jan 18 at 9:24
  • Do you mean, still segfaulting with that specific installer? Did you try removing that pkg sudo mhwd -r pci video-vesa btw?
    – Alsushi
    Jan 18 at 10:06
  • Well it's Arch Linux not Manjaro so pacman -R xf86-video-vesa
    – KNejad
    Jan 18 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.